summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-16 00:21:55 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-16 00:23:11 +0200
commita81c898fd7a69ed4733baa79ac27da7f862161b7 (patch)
treec1f4b224acdd5f3f570fe242a3bd628e75c8861e /gnu/packages/guile.scm
parent25487c3fe6a41dd62f6e53f256392224a3be2a08 (diff)
downloadguix-patches-a81c898fd7a69ed4733baa79ac27da7f862161b7.tar
guix-patches-a81c898fd7a69ed4733baa79ac27da7f862161b7.tar.gz
gnu: guile: Update to 3.0.7.
* gnu/packages/guile.scm (guile-3.0): Update to 3.0.7 by merging with GUILE-3.0-LATEST. (guile-3.0-latest): Define as an alias.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm53
1 files changed, 19 insertions, 34 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 32f96747c9..df3d78fc43 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -291,21 +291,30 @@ without requiring the source code to be rewritten.")
(package
(inherit guile-2.2)
(name "guile")
- (version "3.0.5")
+ (version "3.0.7")
(source (origin
- (inherit (package-source guile-2.2))
+ (inherit (package-source guile-2.2)) ;preserve snippet
+ (patches '())
(uri (string-append "mirror://gnu/guile/guile-"
version ".tar.xz"))
(sha256
(base32
- "1wah6fq1h8vmbpdadjych1mq8hyqkd7p015cbxm14ri37l1gnxid"))))
+ "1dwiwsrpm4f96alfnz6wibq378242z4f16vsxgy1n9r00v3qczgm"))))
+
+ ;; Build with the bundled mini-GMP to avoid interference with GnuTLS' own
+ ;; use of GMP via Nettle: <https://issues.guix.gnu.org/46330>.
+ (propagated-inputs
+ (srfi-1:fold srfi-1:alist-delete
+ (package-propagated-inputs guile-2.2)
+ '("gmp" "libltdl")))
(arguments
- ;; XXX: JIT-enabled Guile crashes in obscure ways on GNU/Hurd.
- (if (hurd-target?)
- (substitute-keyword-arguments (package-arguments guile-2.2)
- ((#:configure-flags flags ''())
- `(cons "--disable-jit" ,flags)))
- (package-arguments guile-2.2)))
+ (substitute-keyword-arguments (package-arguments guile-2.2)
+ ((#:configure-flags flags ''())
+ (let ((flags `(cons "--enable-mini-gmp" ,flags)))
+ ;; XXX: JIT-enabled Guile crashes in obscure ways on GNU/Hurd.
+ (if (hurd-target?)
+ `(cons "--disable-jit" ,flags)
+ flags)))))
(native-search-paths
(list (search-path-specification
(variable "GUILE_LOAD_PATH")
@@ -316,31 +325,7 @@ without requiring the source code to be rewritten.")
"share/guile/site/3.0")))))))
(define-public guile-3.0-latest
- ;; TODO: Make this 'guile-3.0' on the next rebuild cycle.
- (package
- (inherit guile-3.0)
- (version "3.0.7")
- (source (origin
- (inherit (package-source guile-3.0)) ;preserve snippet
- (patches '())
- (uri (string-append "mirror://gnu/guile/guile-"
- version ".tar.xz"))
- (sha256
- (base32
- "1dwiwsrpm4f96alfnz6wibq378242z4f16vsxgy1n9r00v3qczgm"))))
-
- ;; Build with the bundled mini-GMP to avoid interference with GnuTLS' own
- ;; use of GMP via Nettle: <https://issues.guix.gnu.org/46330>. Use
- ;; LIBGC/DISABLE-MUNMAP to work around <https://bugs.gnu.org/40525>.
- ;; Remove libltdl, which is no longer used.
- (propagated-inputs
- `(("bdw-gc" ,libgc/disable-munmap)
- ,@(srfi-1:fold srfi-1:alist-delete (package-propagated-inputs guile-3.0)
- '("gmp" "libltdl" "bdw-gc"))))
- (arguments
- (substitute-keyword-arguments (package-arguments guile-3.0)
- ((#:configure-flags flags ''())
- `(cons "--enable-mini-gmp" ,flags))))))
+ guile-3.0)
(define-public guile-3.0/libgc-7
;; Using libgc-7 avoid crashes that can occur, particularly when loading