summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-24 16:53:13 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-24 16:57:31 +0200
commit9b09a753a9711f7614564272013138fce6fec708 (patch)
treee899b3633cb9b635e852b4806339091584105384 /gnu/packages/guile.scm
parent5b674fe5c317425405075c0deab222cbaed80d83 (diff)
downloadguix-patches-9b09a753a9711f7614564272013138fce6fec708.tar
guix-patches-9b09a753a9711f7614564272013138fce6fec708.tar.gz
gnu: guile@2.2: Build with '-fexcess-precision=standard' on i686.
* gnu/packages/guile.scm (guile-2.2)[arguments]: New field. (guile-3.0)[arguments]: Inherit arguments from GUILE-2.0 instead of GUILE-2.2
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 9fa223713b..5cb7ab23dc 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -270,6 +270,13 @@ without requiring the source code to be rewritten.")
(for-each delete-file
(find-files "prebuilt" "\\.go$"))
#t))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments guile-2.0)
+ ((#:configure-flags flags ''())
+ (if (target-x86-32?) ;<https://issues.guix.gnu.org/49368>
+ `(append ,flags '("CFLAGS=-g -O2 -fexcess-precision=standard"))
+ flags))))
+
(properties '((timeout . 72000) ;20 hours
(max-silent-time . 36000))) ;10 hours (needed on ARM
; when heavily loaded)
@@ -324,7 +331,7 @@ without requiring the source code to be rewritten.")
(package-propagated-inputs guile-2.2)
'("gmp" "libltdl")))
(arguments
- (substitute-keyword-arguments (package-arguments guile-2.2)
+ (substitute-keyword-arguments (package-arguments guile-2.0)
((#:configure-flags flags ''())
;; XXX: JIT-enabled Guile crashes in obscure ways on GNU/Hurd.
`(cons* ,@(if (hurd-target?)
@@ -334,6 +341,8 @@ without requiring the source code to be rewritten.")
;; i686-linux, otherwise "numbers.test" will fail
;; (see <https://issues.guix.gnu.org/49368> and
;; <https://issues.guix.gnu.org/49659>).
+ ;; TODO: Keep this in GUILE-2.2 and remove from here on next
+ ;; rebuild cycle.
,@(if (target-x86-32?)
'("CFLAGS=-g -O2 -fexcess-precision=standard")
'())