summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-09 17:31:00 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-10 18:16:39 +0100
commit98619142b8c54287136216d0008871f9170a1808 (patch)
treec478f5e36aea845eadf97542b2e8469a45a0d7b4 /gnu/packages/guile.scm
parent0e20e2c3871075a8fa117e2139f9ac494e08f0de (diff)
downloadguix-patches-98619142b8c54287136216d0008871f9170a1808.tar
guix-patches-98619142b8c54287136216d0008871f9170a1808.tar.gz
gnu: guile-next: Update to 3.0.1 with bug-fix for crash.
* gnu/packages/guile.scm (guile-3.0): Update to 3.0.1 with "guile-3.0-crash.patch". * gnu/packages/patches/guile-3.0-crash.patch: New file. * gnu/local.mk (dist_patch_DATA): Use it.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 3116f3c30a..1d9d93d774 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -292,14 +292,18 @@ without requiring the source code to be rewritten.")
(package
(inherit guile-2.2)
(name "guile-next") ;to be renamed to "guile"
- (version "3.0.0")
+ (version "3.0.1")
(source (origin
(inherit (package-source guile-2.2))
(uri (string-append "mirror://gnu/guile/guile-"
version ".tar.xz"))
(sha256
(base32
- "0x8ca6q1qdmk29lh12gj6ngvgn7kp79w42rxfgwrpxm9jmjqs4y9"))))
+ "1jakps3127h8g69ixgb4zwc8v2g29dmwql1vi3pwg30kzp8fm5nn"))
+ (patches
+ (append (search-patches "guile-3.0-crash.patch")
+ (origin-patches (package-source guile-2.2))))))
+
(arguments
(substitute-keyword-arguments (package-arguments guile-2.2)
;; XXX: On ARMv7, work around <https://bugs.gnu.org/39208> by disabling