summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-07 21:42:34 +0100
committerLudovic Courtès <ludo@gnu.org>2020-03-07 22:29:44 +0100
commit8ab060b68b3d01ae8546741b77f3df779a8dc61c (patch)
treefbf1e10efdefa8598c6c22561a2dfc5ca3735411 /gnu/packages/guile.scm
parent2519e4cba847574ff65e1d5e24ba5dfa3b95d40c (diff)
downloadguix-patches-8ab060b68b3d01ae8546741b77f3df779a8dc61c.tar
guix-patches-8ab060b68b3d01ae8546741b77f3df779a8dc61c.tar.gz
gnu: guile: Add 2.2.7.
* gnu/packages/guile.scm (guile-2.2.7): New variable. (guile-2.2/bug-fix): Redefine as a deprecated alias for GUILE-2.2.7. * gnu/packages/admin.scm (shepherd)[native-inputs, inputs]: Use GUILE-2.2.7. * gnu/packages/patches/guile-finalization-crash.patch: Remove. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm16
1 files changed, 10 insertions, 6 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index a5466f8672..9c83f3339b 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -250,17 +250,21 @@ without requiring the source code to be rewritten.")
(variable "GUILE_LOAD_COMPILED_PATH")
(files '("lib/guile/2.2/site-ccache")))))))
-(define-public guile-2.2/bug-fix
- ;; This variant contains a bug fix for a relatively rare crash that could
+(define-public guile-2.2.7
+ ;; This version contains a bug fix for a relatively rare crash that could
;; affect shepherd as PID 1: <https://bugs.gnu.org/37757>.
(package
(inherit guile-2.2)
- (version (string-append (package-version guile-2.2) "-1"))
+ (version "2.2.7")
(source (origin
(inherit (package-source guile-2.2))
- (patches
- (append (search-patches "guile-finalization-crash.patch")
- (origin-patches (package-source guile-2.2))))))))
+ (uri (string-append "mirror://gnu/guile/guile-" version
+ ".tar.xz"))
+ (sha256
+ (base32
+ "013mydzhfswqci6xmyc1ajzd59pfbdak15i0b090nhr9bzm7dxyd"))))))
+
+(define-deprecated guile-2.2/bug-fix guile-2.2.7)
(define-public guile-2.2/fixed
;; A package of Guile 2.2 that's rarely changed. It is the one used