summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-06 15:18:33 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-06 15:19:10 +0200
commit78dab5a6c4979a62c3ff3df977d895a840c7ef20 (patch)
tree047fe59130a0b60164a2c3b355598b10b51695b1 /gnu/packages/guile.scm
parentb792bc899d4c88b8ccd50659c7dcccb3271200d1 (diff)
downloadguix-patches-78dab5a6c4979a62c3ff3df977d895a840c7ef20.tar
guix-patches-78dab5a6c4979a62c3ff3df977d895a840c7ef20.tar.gz
gnu: guile@1.8: Disable tests.
* gnu/packages/guile.scm (guile-1.8)[arguments]: Pass #:tests? #f.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index b0b6b16ff9..35859ee452 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -110,8 +110,13 @@
;; The usual /bin/sh...
(substitute* "ice-9/popen.scm"
- (("/bin/sh") (which "sh")))
- #t)))))
+ (("/bin/sh") (which "sh"))))))
+
+ ;; XXX: Several numerical tests and tests related to
+ ;; 'inet-pton' fail on glibc 2.33/GCC 10. Disable them.
+ ;; TODO: Remove this package when its dependents no longer
+ ;; need it.
+ #:tests? #f))
;; When cross-compiling, a native version of Guile itself is needed.
(native-inputs (if (%current-target-system)