summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-12-09 17:17:07 +0100
committerLudovic Courtès <ludo@gnu.org>2019-12-09 18:32:05 +0100
commit4bd6f1d1d65b90ca90c3305404d820c5f4ca4427 (patch)
tree474a3731b08631933d8236721541005a8d7ffa51 /gnu/packages/guile.scm
parent9a05da36b5945c49f17de846b50eb55d5ab7ff52 (diff)
downloadguix-patches-4bd6f1d1d65b90ca90c3305404d820c5f4ca4427.tar
guix-patches-4bd6f1d1d65b90ca90c3305404d820c5f4ca4427.tar.gz
gnu: guile: Add 2.2.6-1 with a finalization crash bug-fix.
* gnu/packages/patches/guile-finalization-crash.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/guile.scm (guile-2.2/bug-fix): New variable.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 33968996e6..9df008c413 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -250,6 +250,18 @@ without requiring the source code to be rewritten.")
(variable "GUILE_LOAD_COMPILED_PATH")
(files '("lib/guile/2.2/site-ccache")))))))
+(define-public guile-2.2/bug-fix
+ ;; This variant contains a bug fix for a relatively rare crash that could
+ ;; affect shepherd as PID 1: <https://bugs.gnu.org/37757>.
+ (package
+ (inherit guile-2.2)
+ (version (string-append (package-version guile-2.2) "-1"))
+ (source (origin
+ (inherit (package-source guile-2.2))
+ (patches
+ (append (search-patches "guile-finalization-crash.patch")
+ (origin-patches (package-source guile-2.2))))))))
+
(define-public guile-2.2/fixed
;; A package of Guile 2.2 that's rarely changed. It is the one used
;; in the `base' module, and thus changing it entails a full rebuild.