summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-05-12 23:34:44 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-13 00:19:58 +0200
commit47d48f0c43c13c0b43bc3e37b6239efd4bf2f74c (patch)
treedab4701daa0beb55108eaf1843ff0689a42bfbf3 /gnu/packages/guile.scm
parent3320b70f4dbb9bd8d4f782975111f32d0d045edb (diff)
downloadguix-patches-47d48f0c43c13c0b43bc3e37b6239efd4bf2f74c.tar
guix-patches-47d48f0c43c13c0b43bc3e37b6239efd4bf2f74c.tar.gz
gnu: guile: Update to 3.0.7.
* gnu/packages/guile.scm (guile-3.0-latest): Update to 3.0.7. Remove "guile-2.2-skip-so-test.patch". [propagated-inputs, arguments]: New fields.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm36
1 files changed, 23 insertions, 13 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 88a0e52e8a..91fcf46336 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -311,19 +311,29 @@ without requiring the source code to be rewritten.")
(define-public guile-3.0-latest
;; TODO: Make this 'guile-3.0' on the next rebuild cycle.
- (package-with-extra-patches
- (package
- (inherit guile-3.0)
- (version "3.0.5")
- (source (origin
- (inherit (package-source guile-3.0))
- (uri (string-append "mirror://gnu/guile/guile-"
- version ".tar.xz"))
- (sha256
- (base32
- "1wah6fq1h8vmbpdadjych1mq8hyqkd7p015cbxm14ri37l1gnxid")))))
- ;; Remove on the next rebuild cycle.
- (search-patches "guile-2.2-skip-so-test.patch")))
+ (package
+ (inherit guile-3.0)
+ (version "3.0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/guile/guile-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1dwiwsrpm4f96alfnz6wibq378242z4f16vsxgy1n9r00v3qczgm"))))
+
+ ;; Build with the bundled mini-GMP to avoid interference with GnuTLS' own
+ ;; use of GMP via Nettle: <https://issues.guix.gnu.org/46330>. Use
+ ;; LIBGC/DISABLE-MUNMAP to work around <https://bugs.gnu.org/40525>.
+ ;; Remove libltdl, which is no longer used.
+ (propagated-inputs
+ `(("bdw-gc" ,libgc/disable-munmap)
+ ,@(srfi-1:fold srfi-1:alist-delete (package-propagated-inputs guile-3.0)
+ '("gmp" "libltdl" "bdw-gc"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments guile-3.0)
+ ((#:configure-flags flags ''())
+ `(cons "--enable-mini-gmp" ,flags))))))
(define-public guile-3.0/libgc-7
;; Using libgc-7 avoid crashes that can occur, particularly when loading