summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-07 18:59:46 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-08 00:28:57 +0200
commit285f3b58c6665ea9e347f5a5df1fc26fe49dc7bb (patch)
tree19f890281801226b11a842add81d1254c6620085 /gnu/packages/guile.scm
parent145a5a5797f0f673c817d99760d1c1e5d71aa11c (diff)
downloadguix-patches-285f3b58c6665ea9e347f5a5df1fc26fe49dc7bb.tar
guix-patches-285f3b58c6665ea9e347f5a5df1fc26fe49dc7bb.tar.gz
gnu: guile: Skip 'test-stack-overflow'.
* gnu/packages/guile.scm (guile-3.0)[arguments]: Add 'disable-stack-overflow-test' phase.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm40
1 files changed, 24 insertions, 16 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 0012d919c8..c8cdfbe269 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -324,22 +324,30 @@ without requiring the source code to be rewritten.")
`(cons "--disable-jit" ,flags)
flags)))
((#:phases phases)
- (if (string-prefix? "powerpc-" (%current-system))
- `(modify-phases ,phases
- (add-after 'unpack 'adjust-bootstrap-flags
- (lambda _
- ;; Upstream knows about suggested solution.
- ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=45214
- (substitute* "bootstrap/Makefile.in"
- (("^GUILE_OPTIMIZATIONS.*")
- "GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n"))))
- (add-after 'unpack 'skip-failing-fdes-test
- (lambda _
- ;; ERROR: ((system-error "seek" "~A" ("Bad file descriptor") (9)))
- (substitute* "test-suite/tests/ports.test"
- (("fdes not closed\"" all) (string-append all "(exit 77)")))
- #t)))
- phases))))
+ `(modify-phases ,phases
+ (add-before 'check 'disable-stack-overflow-test
+ (lambda _
+ ;; This test can invoke the "OOM killer", especially when
+ ;; running on emulated hardware (QEMU). Skip it.
+ (substitute* "test-suite/standalone/test-stack-overflow"
+ (("!#")
+ "!#\n(exit 77)\n"))))
+
+ ,@(if (string-prefix? "powerpc-" (%current-system))
+ `((add-after 'unpack 'adjust-bootstrap-flags
+ (lambda _
+ ;; Upstream knows about suggested solution.
+ ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=45214
+ (substitute* "bootstrap/Makefile.in"
+ (("^GUILE_OPTIMIZATIONS.*")
+ "GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n"))))
+ (add-after 'unpack 'skip-failing-fdes-test
+ (lambda _
+ ;; ERROR: ((system-error "seek" "~A" ("Bad file descriptor") (9)))
+ (substitute* "test-suite/tests/ports.test"
+ (("fdes not closed\"" all) (string-append all "(exit 77)")))
+ #t)))
+ '())))))
(native-search-paths
(list (search-path-specification