summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-20 11:31:17 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-20 21:53:53 +0100
commit25623647e9c6f5cafea902ac3d8d6d7ac03c0b3c (patch)
tree32cc645be024f41606b19982257dd1a736bd493b /gnu/packages/guile.scm
parent89595f98d05a159d24f951fbc217e1a8d6f6e6c0 (diff)
downloadguix-patches-25623647e9c6f5cafea902ac3d8d6d7ac03c0b3c.tar
guix-patches-25623647e9c6f5cafea902ac3d8d6d7ac03c0b3c.tar.gz
gnu: guile-git: Update to 0.3.0.
* gnu/packages/guile.scm (guile-git): Update to 0.3.0. [source]: Download tarball with URL-FETCH. [source](file-name, modules, snippet): Remove. [native-inputs]: Remove AUTOCONF, AUTOMAKE and TEXINFO.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm31
1 files changed, 7 insertions, 24 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index e940d38b17..c8c44b7fcb 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -634,36 +634,19 @@ type system, elevating types to first-class status.")
(define-public guile-git
(package
(name "guile-git")
- (version "0.2.0")
+ (version "0.3.0")
(home-page "https://gitlab.com/guile-git/guile-git.git")
(source (origin
- (method git-fetch)
- (uri (git-reference (url home-page)
- (commit (string-append "v" version))))
+ (method url-fetch)
+ (uri (string-append "https://gitlab.com/guile-git/guile-git/uploads/"
+ "4c563d8e7e1ff84396abe8ca7011bcaf/guile-git-"
+ version ".tar.gz"))
(sha256
(base32
- "018hmfsh0rjwfvr4h7y10jc6k8a2k9xsirngghy3pjasin4nd2yz"))
- (file-name (git-file-name name version))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Allow builds with Guile 3.0.
- (substitute* "configure.ac"
- (("^GUILE_PKG.*")
- "GUILE_PKG([3.0 2.2 2.0])\n"))
-
- ;; The 'guile.m4' that's shipped is too old and fails to
- ;; recognize Guile 2.9/3.0. Delete it and pick the one
- ;; provided by the Guile we're using.
- (delete-file "m4/guile.m4")
-
- #t))))
+ "0c5i3d16hp7gp9rd78vk9zc45js8bphf92m4lbb5gyi4l1yl7kkm"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("texinfo" ,texinfo)
- ("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)))
(inputs
`(("guile" ,guile-2.2)
("libgit2" ,libgit2)))