summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-01-11 11:29:00 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-01-11 12:06:12 +0100
commit21cf0d36db9f02b3da976088b5ab466822d16625 (patch)
tree913e347c63bdf5d3c578d4be0d0ed8b166a7d339 /gnu/packages/guile.scm
parentb54b3f5419849286611279231d8a2c61d3e935b4 (diff)
downloadguix-patches-21cf0d36db9f02b3da976088b5ab466822d16625.tar
guix-patches-21cf0d36db9f02b3da976088b5ab466822d16625.tar.gz
gnu: guile: Fix tests on emulated architectures.
The stack overflow test limits the virtual memory size using setrlimit with RLIMIT_AS argument. This is ignored when using QEMU transparent emulation, causing the test to crash. * gnu/packages/patches/guile-2.2-skip-so-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/guile.scm (guile-3.0-latest): Add it.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 1c983e50eb..dfba797b79 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -310,16 +310,19 @@ without requiring the source code to be rewritten.")
(define-public guile-3.0-latest
;; TODO: Make this 'guile-3.0' on the next rebuild cycle.
- (package
- (inherit guile-3.0)
- (version "3.0.5")
- (source (origin
- (inherit (package-source guile-3.0))
- (uri (string-append "mirror://gnu/guile/guile-"
- version ".tar.xz"))
- (sha256
- (base32
- "1wah6fq1h8vmbpdadjych1mq8hyqkd7p015cbxm14ri37l1gnxid"))))))
+ (package-with-extra-patches
+ (package
+ (inherit guile-3.0)
+ (version "3.0.5")
+ (source (origin
+ (inherit (package-source guile-3.0))
+ (uri (string-append "mirror://gnu/guile/guile-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1wah6fq1h8vmbpdadjych1mq8hyqkd7p015cbxm14ri37l1gnxid")))))
+ ;; Remove on the next rebuild cycle.
+ (search-patches "guile-2.2-skip-so-test.patch")))
(define-public guile-next
(deprecated-package "guile-next" guile-3.0))