summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-01-30 23:11:06 +0100
committerLudovic Courtès <ludo@gnu.org>2022-02-01 00:24:22 +0100
commit1ebc702923d4398652e684960cfbb8b026e895c1 (patch)
tree7f6666d325084e903192e834630586d3bd786644 /gnu/packages/guile.scm
parente96edb056d128e6b592d46071086578312a440de (diff)
downloadguix-patches-1ebc702923d4398652e684960cfbb8b026e895c1.tar
guix-patches-1ebc702923d4398652e684960cfbb8b026e895c1.tar.gz
gnu: Add Lokke.
* gnu/packages/guile.scm (guile-3.0-for-lokke): New variable. * gnu/packages/guile-xyz.scm (lokke): New variable. * gnu/packages/patches/guile-3.0.7-psyntax-nil.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 6cfd609916..7597845dd6 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -391,6 +391,17 @@ without requiring the source code to be rewritten.")
(define-public guile-3.0-latest
guile-3.0)
+(define-public guile-3.0-for-lokke
+ ;; Work around a bug in 3.0.7 regarding #nil handling by psyntax:
+ ;; <https://bugs.gnu.org/49305>. TODO: Replace by 3.0.8 when it's out.
+ (hidden-package
+ (package/inherit guile-3.0
+ (version (string-append (package-version guile-3.0) ".1"))
+ (source (origin
+ (inherit (package-source guile-3.0))
+ (patches (cons (search-patch "guile-3.0.7-psyntax-nil.patch")
+ (origin-patches (package-source guile-3.0)))))))))
+
(define-public guile-3.0/libgc-7
;; Using libgc-7 avoid crashes that can occur, particularly when loading
;; data in to the Guix Data Service: