summaryrefslogtreecommitdiff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-12-29 21:21:49 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-12-29 21:26:12 +0100
commit16e42db095eb7dff1ed93f2321ee743257e2b821 (patch)
treed61c1dad1de493dc34f95fac034e8a7f4316feb6 /gnu/packages/guile.scm
parent247a47bc402371d98486904b6bfa860ade9c9e8a (diff)
downloadguix-patches-16e42db095eb7dff1ed93f2321ee743257e2b821.tar
guix-patches-16e42db095eb7dff1ed93f2321ee743257e2b821.tar.gz
gnu: guile-bytestructures: Switch to git-fetch.
* gnu/packages/guile.scm (guile-bytestructures)[home-page]: Move up, [source]: switch form url-fetch to git-fetch method, [native-inputs]: add autoconf and automake.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 03aa474bd9..daac970848 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -585,20 +585,22 @@ Guile's foreign function interface.")
(package
(name "guile-bytestructures")
(version "1.0.7")
+ (home-page "https://github.com/TaylanUB/scheme-bytestructures")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/TaylanUB/scheme-bytestructures"
- "/releases/download/v" version
- "/bytestructures-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
(sha256
(base32
"0q0habjiy3h9cigb7q1br9kz6z212dn2ab31f6dgd3rrmsfn5rvb"))))
(build-system gnu-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("guile" ,guile-2.2)))
- (home-page "https://github.com/TaylanUB/scheme-bytestructures")
(synopsis "Structured access to bytevector contents for Guile")
(description
"Guile bytestructures offers a system imitating the type system