summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-05-28 17:21:52 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-05-28 18:00:21 +0200
commitd1fa24afefa2efa4f11f17cacaaab700a290647c (patch)
tree1a279325b4c8c671c5cb09dc9e0d10c1cab6a6e1 /gnu/packages/guile-xyz.scm
parent0d796201db2188e0a3abb6522f65458720b46fa6 (diff)
downloadguix-patches-d1fa24afefa2efa4f11f17cacaaab700a290647c.tar
guix-patches-d1fa24afefa2efa4f11f17cacaaab700a290647c.tar.gz
gnu: Add guile-jsonld.
* gnu/packages/guile-xyz.scm (guile-jsonld): New variable.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index c7349af790..6a8bf54bf8 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3646,3 +3646,40 @@ operations on graphs. This library implements some basic functionalities,
such as parsing and producing turtle and nquads syntax, as well as
manipulating graphs and datasets.")
(license license:gpl3+)))
+
+(define-public guile-jsonld
+ (package
+ (name "guile-jsonld")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://framagit.org/tyreunom/guile-jsonld")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zfn3nwlz6xzip1j8xbj768dc299r037cfc81bk6kwl9xhzkjbrg"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)); require network
+ (propagated-inputs
+ `(("guile-gnutls" ,gnutls)
+ ("guile-json" ,guile-json-3)
+ ("guile-rdf" ,guile-rdf)))
+ (inputs
+ `(("guile" ,guile-3.0)))
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (home-page "https://framagit.org/tyreunom/guile-jsonld")
+ (synopsis "Guile implementation of the JsonLD API specification")
+ (description "Guile JsonLD is an implementation of the JsonLD (Json for
+Linked Data) API defined by the W3C for GNU Guile. It allows you to express links
+between data, in a way that is very similar to WikiData or RDF for instance.
+An object can have relations (in the form of an IRI) that relates it to one or
+more objects or strings, represented by a Json object or an IRI.")
+ (license license:gpl3+)))