summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-09 22:40:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-09 22:41:14 +0200
commitb97b4624d085c3d6137a1c543088a68ec85f8f58 (patch)
treef565a5bdf528b68ac3ed733938e4c74274f58aa1 /gnu/packages/guile-xyz.scm
parentae623b3f9d53c054cc9cd794108d9df6b02ff570 (diff)
downloadguix-patches-b97b4624d085c3d6137a1c543088a68ec85f8f58.tar
guix-patches-b97b4624d085c3d6137a1c543088a68ec85f8f58.tar.gz
gnu: Add guile-file-names.
* gnu/packages/guile-xyz.scm (guile-file-names): New variable.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 03fd63837e..c640893e32 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2195,3 +2195,42 @@ serializing continuations or delimited continuations.")
"This package allows you to compile a Guile Python file to any target
from @code{tree-il}.")
(license license:lgpl2.0+))))
+
+(define-public guile-file-names
+ (package
+ (name "guile-file-names")
+ (version "0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://brandon.invergo.net/software/download/"
+ "guile-file-names/guile-file-names-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "01ba6jdypj9cwc5rgiw384dgz12iz6ab4dsd3ai5gfklprm2a50b"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'build-with-guile-2.2
+ (lambda _
+ (substitute* "configure"
+ (("guile-2.0") "guile-2.2"))
+ (substitute* "file-names/Makefile.in"
+ (("guilemoddir = \\$\\(GUILE_SITE\\)")
+ "guilemoddir = $(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
+ #t)))))
+ (inputs
+ `(("guile" ,guile-2.2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://gitlab.com/brandoninvergo/guile-file-names")
+ (synopsis "Manipulate file names")
+ (description
+ "The @code{(file-names)} module provides tools for manipulating file
+names. The module was built on the idea that doing anything more than a
+non-trivial modification of a file name string is a pain (making sure all
+slashes are present and accounted for, resolving @code{.} and @code{..}, etc).
+Inevitably, you have to break the string up into chunks and operate on that
+list of components. This module takes care of that for you.")
+ (license license:lgpl3+)))