summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-11-25 00:11:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-11-25 14:05:39 +0100
commitb5d4d5b9bcf267fddd02fcc14b88eac0bebf979f (patch)
tree1e2fdec19ab52cdefa88d9266b328914f622e0df /gnu/packages/guile-xyz.scm
parentea2884c12ce089392c01b63f84e29a4ebaa0e16b (diff)
downloadguix-patches-b5d4d5b9bcf267fddd02fcc14b88eac0bebf979f.tar
guix-patches-b5d4d5b9bcf267fddd02fcc14b88eac0bebf979f.tar.gz
gnu: guile-gi: Update to 0.2.1.
* gnu/packages/guile-xyz.scm (guile-gi): Update to 0.2.1. [arguments]: Add phase to start Xorg server for tests. [native-inputs]: Add xorg-server.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 245eb9c0d6..e2eee47457 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2255,22 +2255,32 @@ list of components. This module takes care of that for you.")
(define-public guile-gi
(package
(name "guile-gi")
- (version "0.2.0")
+ (version "0.2.1")
(source (origin
(method url-fetch)
(uri (string-append "http://lonelycactus.com/tarball/guile_gi-"
version ".tar.gz"))
(sha256
(base32
- "1n4pbrmbrjkrx826a4m31ag5c35rgkj1sirqh4qalk7gg67cfb41"))))
+ "1ah5bmkzplsmkrk7v9vlxlqch7i91qv4cq2d2nar9xshbpcrj484"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--with-gnu-filesystem-hierarchy")))
+ `(#:configure-flags '("--with-gnu-filesystem-hierarchy")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'start-xorg-server
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; The init_check test requires a running X server.
+ (system (format #f "~a/bin/Xvfb :1 &"
+ (assoc-ref inputs "xorg-server")))
+ (setenv "DISPLAY" ":1")
+ #t)))))
(native-inputs
`(("gettext" ,gnu-gettext)
("glib:bin" ,glib "bin") ; for glib-compile-resources
("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("xorg-server" ,xorg-server)))
(propagated-inputs
`(("glib" ,glib)
("gobject-introspection" ,gobject-introspection)