summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-03-05 23:04:19 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-13 14:58:28 +0100
commitaa0598974b9c454dcce0a7a4aba1a0198bce8b93 (patch)
treef2faeb794c163637e10dcbfea69403a4b6426da4 /gnu/packages/guile-xyz.scm
parente06b1ebcaa19dc80016d7ebff05d590a829dd930 (diff)
downloadguix-patches-aa0598974b9c454dcce0a7a4aba1a0198bce8b93.tar
guix-patches-aa0598974b9c454dcce0a7a4aba1a0198bce8b93.tar.gz
gnu: Add guile-f-scm.
* gnu/packages/guile-xyz.scm (guile-f-scm): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 115c3d82f5..4799711c66 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -34,6 +34,7 @@
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2020, 2021 pukkamustard <pukkamustard@posteo.net>
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -237,6 +238,30 @@ more.")
(home-page "https://www.gnu.org/software/artanis/")
(license (list license:gpl3+ license:lgpl3+)))) ;dual license
+(define-public guile-f-scm
+ (package
+ (name "guile-f-scm")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~brown121407/f.scm")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14wyrs3m1649l3km4pl2175dmap1372j5h8nkhykrbxg5xqp6ivd"))))
+ (build-system guile-build-system)
+ (native-inputs
+ `(("guile" ,guile-3.0)))
+ (home-page "https://git.sr.ht/~brown121407/f.scm")
+ (synopsis "Library for working with files and directories")
+ (description
+ "f.scm is a library intended to facilitate working with files and
+directories (the file system in general). It was initially inspired by the
+f library for Emacs.")
+ (license license:gpl3+)))
+
;; There has not been any release yet.
(define-public guildhall
(let ((commit "2fe2cc539f4b811bbcd69e58738db03eb5a2b778")