summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2022-08-08 17:13:30 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-08 17:13:30 +0200
commita8868a53ade4269bd7f48d805daf39257cb5954a (patch)
tree8091bf8bd180b107921782b943abedbd77b98da1 /gnu/packages/guile-xyz.scm
parentec6499aad231b8a5991f38c1ec982be4b3598837 (diff)
downloadguix-patches-a8868a53ade4269bd7f48d805daf39257cb5954a.tar
guix-patches-a8868a53ade4269bd7f48d805daf39257cb5954a.tar.gz
gnu: guile-parted: Update to 0.0.6.
Fix cross-compilation. * gnu/packages/guile-xyz.scm (guile-parted): Update to 0.0.6. [native-inputs]: Add guile-3.0 and guile-bytestructures.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 33d64018d3..cf7f3e6774 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1393,7 +1393,7 @@ microblogging service.")
(define-public guile-parted
(package
(name "guile-parted")
- (version "0.0.5")
+ (version "0.0.6")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1402,18 +1402,18 @@ microblogging service.")
(file-name (git-file-name name version))
(sha256
(base32
- "1ar6n38br3h1jm54yy6d54rpqdgsy7pmnj3nqdzqrfk8z0kx0rm9"))
+ "12ygz0dw8zjr8g3z4g3sh4d1yw3fiphh0ssyqd4nllqa3sfwv21f"))
(modules '((guix build utils)))))
(build-system gnu-build-system)
(arguments
'(#:make-flags
'("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (native-inputs
+ (list autoconf automake guile-3.0 guile-bytestructures pkg-config))
(inputs
(list guile-3.0 parted))
(propagated-inputs
(list guile-bytestructures))
- (native-inputs
- (list autoconf automake pkg-config))
(synopsis "Guile bindings to GNU Parted")
(description
"This package provides bindings for GNU Parted library, a C library