summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-11-25 10:51:07 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-11-25 10:51:07 +0530
commit4fd6aabeaabae9184407276f3ae2436284bbcf63 (patch)
treeb197d05189484c575e7269c3e15a4ae5e5c6d49c /gnu/packages/guile-xyz.scm
parent29b594fa16254e4d228a2ca0ef6463a805d4c036 (diff)
downloadguix-patches-4fd6aabeaabae9184407276f3ae2436284bbcf63.tar
guix-patches-4fd6aabeaabae9184407276f3ae2436284bbcf63.tar.gz
gnu: guile-libyaml: Update to 0-2.2bdacb7.
* gnu/packages/guile-xyz.scm (guile-libyaml): Update to 0-2.2bdacb7. [arguments]: Do not attempt to delete non-existent files. Use (system ffi-help-rt) from nyacc package. Do not return #t from custom phases. [native-inputs]: Move nyacc to ... [propagated-inputs]: ... here.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm27
1 files changed, 7 insertions, 20 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 628d81710a..abff2c696e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4589,8 +4589,8 @@ schedulers.")
(license license:gpl3+)))
(define-public guile-libyaml
- (let ((commit "f5d33a6880e96571d3cb079ed7755ffc156cac46")
- (revision "1"))
+ (let ((commit "2bdacb72a65ab63264b2edc9dac9692df7ec9b3e")
+ (revision "2"))
(package
(name "guile-libyaml")
(version (git-version "0" revision commit))
@@ -4603,7 +4603,7 @@ schedulers.")
(file-name (git-file-name name version))
(sha256
(base32
- "12x91983fh1j39zy7kbk19acc1rqdh8515ddx1mh7l26j04k9wgq"))))
+ "1bssby1ri1vjll2rvi8b33xr2ghwjyxsd4yc15najj3h8n2ss87i"))))
(build-system gnu-build-system)
(arguments
`(#:modules (((guix build guile-build-system)
@@ -4617,28 +4617,16 @@ schedulers.")
(delete 'configure)
(add-after 'unpack 'remove-unused-files
(lambda* (#:key inputs #:allow-other-keys)
- (for-each delete-file
- '("guix.scm" "demo1.yml" "demo1.scm"
- "yaml/libyaml.scm"
- ;; This file is mismatched with the generated FFI code.
- "yaml/ffi-help-rt.scm"))
- (copy-file (string-append (assoc-ref inputs "nyacc")
- "/share/guile/site/3.0/system/ffi-help-rt.scm")
- "yaml/ffi-help-rt.scm")
- (substitute* "yaml/ffi-help-rt.scm"
- (("system ffi-help-rt") "yaml ffi-help-rt"))
- #true))
+ (for-each delete-file '("guix.scm" "demo1.yml" "demo1.scm"))))
(add-before 'build 'build-ffi
(lambda* (#:key inputs #:allow-other-keys)
(invoke "guild" "compile-ffi"
"--no-exec" ; allow us to patch the generated file
"yaml/libyaml.ffi")
(substitute* "yaml/libyaml.scm"
- (("system ffi-help-rt") "yaml ffi-help-rt")
(("dynamic-link \"libyaml\"")
(format #false "dynamic-link \"~a/lib/libyaml\""
- (assoc-ref inputs "libyaml"))))
- #true))
+ (assoc-ref inputs "libyaml"))))))
(replace 'build
(assoc-ref guile:%standard-phases 'build))
(delete 'install))))
@@ -4646,9 +4634,8 @@ schedulers.")
`(("guile" ,guile-3.0)
("libyaml" ,libyaml)))
(propagated-inputs
- `(("guile-bytestructures" ,guile-bytestructures)))
- (native-inputs
- `(("nyacc" ,nyacc)))
+ `(("guile-bytestructures" ,guile-bytestructures)
+ ("nyacc" ,nyacc)))
(home-page "https://github.com/mwette/guile-libyaml")
(synopsis "Guile wrapper for libyaml")
(description