summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-03-09 14:39:24 -0500
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-03-21 12:05:54 +0100
commit4cd88522f233dcb9affa3d3b0eada154439487c1 (patch)
tree3ee47a4f94b82f80489dc32c119ce0de90009764 /gnu/packages/guile-xyz.scm
parentaa24d2d44c8ed972e4b233f7e6712293352a019c (diff)
downloadguix-patches-4cd88522f233dcb9affa3d3b0eada154439487c1.tar
guix-patches-4cd88522f233dcb9affa3d3b0eada154439487c1.tar.gz
gnu: Add guile-quickcheck.
* gnu/packages/guile-xyz.scm (guile-quickcheck): New variable.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 9f4118f083..28e7c798a7 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 swedebugia <swedebugia@riseup.net>
;;; Copyright © 2019, 2020 Amar Singh <nly@disroot.org>
-;;; Copyright © 2019 Timothy Sample <samplet@ngyro.com>
+;;; Copyright © 2019, 2021 Timothy Sample <samplet@ngyro.com>
;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
@@ -4619,3 +4619,28 @@ binary which is smaller and faster to generate and parse. This package provides
a Guile implementation of CBOR.")
(home-page "https://inqlab.net/git/guile-cbor.git")
(license license:gpl3+)))
+
+(define-public guile-quickcheck
+ (package
+ (name "guile-quickcheck")
+ (version "0.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://files.ngyro.com/"
+ "guile-quickcheck/guile-quickcheck-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "03mwi1l3354x52nar0zwhcm0x29yai9xjln4p4gbchwvx5dsr6fb"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-3.0)))
+ (home-page "https://ngyro.com/software/guile-quickcheck.html")
+ (synopsis "Randomized property-based testing for Guile")
+ (description "Guile-Quickcheck is a library for random testing of program
+properties inspired by ghc-quickcheck. You can use it to express properties,
+which functions should satisfy, as Scheme code and then check whether they hold
+in a large number of randomly generated test cases.")
+ (license license:gpl3+)))