summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-20 10:17:38 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-20 10:17:38 +0200
commit30ebff69a75fe90a1694ef35cf6e749ec376b67e (patch)
treee51592928df970dc5dd6d886e0e9652bd1e84c97 /gnu/packages/guile-xyz.scm
parent8c7453cee79186ee6df429149e2914b96e6d8a9e (diff)
downloadguix-patches-30ebff69a75fe90a1694ef35cf6e749ec376b67e.tar
guix-patches-30ebff69a75fe90a1694ef35cf6e749ec376b67e.tar.gz
gnu: mcron: Update to 1.1.3.
* gnu/packages/guile-xyz.scm (mcron): Update to 1.1.3. [arguments]: Add phase to allow building with guile-2.2. [native-inputs]: Remove autoconf, automake, help2man, texinfo.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 49ef5f2892..1e676566ac 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1921,17 +1921,22 @@ is no support for parsing block and inline level HTML.")
(define-public mcron
(package
(name "mcron")
- (version "1.1.2")
+ (version "1.1.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/mcron/mcron-"
version ".tar.gz"))
(sha256
(base32
- "069m3ri7nc8lgy3h9ka7gj3v3anqj69x9jw4l3cfq65nqkxsch4g"))))
+ "00kv7fgllzjpis0g1m9csycp4f6l11774m09dqy255cvmim2g743"))))
(build-system gnu-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'fix-finding-guile
+ (lambda _
+ (substitute* "configure"
+ (("2\\.0") "2.2 2.0"))
+ #t))
(add-before 'check 'adjust-tests
(lambda _
(substitute* "tests/job-specifier.scm"
@@ -1948,11 +1953,7 @@ is no support for parsing block and inline level HTML.")
(("\\(test-equal \"next-year\"" all)
(string-append "(test-skip 4)\n" all)))
#t)))))
- (native-inputs `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("help2man" ,help2man)
- ("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)
+ (native-inputs `(("pkg-config" ,pkg-config)
("tzdata" ,tzdata-for-tests)))
(inputs `(("guile" ,guile-2.2)))
(home-page "https://www.gnu.org/software/mcron/")