summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-07-25 14:11:51 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-07-25 14:47:47 +0200
commit20df47e5a390399775908d96e552d7a6696c50bb (patch)
treed6697b0e46c54ff73551934a615465e54775b40f /gnu/packages/guile-xyz.scm
parent8e969204d5802fa9d9ff20e321384e112e82c463 (diff)
downloadguix-patches-20df47e5a390399775908d96e552d7a6696c50bb.tar
guix-patches-20df47e5a390399775908d96e552d7a6696c50bb.tar.gz
gnu: Add guile-zlib.
* gnu/packages/guile-xyz.scm (guile-zlib): New variable.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 21f998524e..0bfb855f46 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3693,3 +3693,36 @@ between data, in a way that is very similar to WikiData or RDF for instance.
An object can have relations (in the form of an IRI) that relates it to one or
more objects or strings, represented by a Json object or an IRI.")
(license license:gpl3+)))
+
+(define-public guile-zlib
+ (package
+ (name "guile-zlib")
+ (version "0.0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://notabug.org/guile-zlib/guile-zlib.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "139ixlg0663azwpcj24sw27kmzxr5am0j6hn62ffjchi9w1qb3k0"))
+ (modules '((guix build utils)))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:make-flags
+ '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("guile" ,guile-3.0)
+ ("zlib" ,zlib)))
+ (synopsis "Guile bindings to zlib")
+ (description
+ "This package provides Guile bindings for zlib, a lossless
+data-compression library. The bindings are written in pure Scheme by using
+Guile's foreign function interface.")
+ (home-page "https://notabug.org/guile-zlib/guile-zlib")
+ (license license:gpl3+)))