summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2020-12-07 12:55:38 +0100
committerLudovic Courtès <ludo@gnu.org>2020-12-12 20:57:33 +0100
commit208cb960672ccb6b36b82070ae8346d23159a469 (patch)
treeaadc83ffe0cb57e673317d16f9fe7c270bd00b9f /gnu/packages/guile-xyz.scm
parentf53c1005248963dfe8765c8c8c3489a156066ef8 (diff)
downloadguix-patches-208cb960672ccb6b36b82070ae8346d23159a469.tar
guix-patches-208cb960672ccb6b36b82070ae8346d23159a469.tar.gz
gnu: Add guile-eris.
* gnu/packages/guile-xyz.scm (guile-eris): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 77819f5b01..dfffbfc62f 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4207,3 +4207,36 @@ which provides core cryptographic primitives needed to build higher-level
tools.")
(home-page "https://inqlab.net/git/guile-sodium.git")
(license license:gpl3+)))
+
+(define-public guile-eris
+ (package
+ (name "guile-eris")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://inqlab.net/git/eris.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256 (base32 "1ijglmwkdy1l87gj429qfjis0v8b1zlxhbyfhx5za8664h68nqka"))))
+ (build-system gnu-build-system)
+ (arguments '())
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)
+ ;; test dependency
+ ("guile-srfi-180" ,guile-srfi-180)))
+ (inputs `(("guile" ,guile-3.0)))
+ (propagated-inputs
+ `(("guile-sodium" ,guile-sodium)))
+ (synopsis "Guile implementation of the Encoding for Robust Immutable Storage (ERIS)")
+ (description
+ "Guile-ERIS is the reference implementation of the Encoding for Robust
+Immutable Storage (ERIS). ERIS allows arbirtary content to be encoded into
+uniformly sized, encrypted blocks that can be reassembled using a short
+read-capability.")
+ (home-page "https://inqlab.net/git/eris.git")
+ (license license:gpl3+)))