summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-23 16:32:06 +0200
committerMarius Bakke <marius@gnu.org>2020-06-24 01:04:15 +0200
commit09f0bc87a9efa2106b8b5333abc55f4db1b55cc4 (patch)
treeceb9789a86b0f9c81f39d9c27a344fbfd253773b /gnu/packages/guile-xyz.scm
parent3a71dac02ed9b6bc8c71c1e332205ac067173b17 (diff)
downloadguix-patches-09f0bc87a9efa2106b8b5333abc55f4db1b55cc4.tar
guix-patches-09f0bc87a9efa2106b8b5333abc55f4db1b55cc4.tar.gz
gnu: guile-persist: Update to 1.2.3.
* gnu/packages/guile-xyz.scm (guile-persist): Update to 1.2.3. [source](modules, snippet): Remove. [inputs]: Change from GUILE-2.2 to GUILE-3.0.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm101
1 files changed, 45 insertions, 56 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 4dbb256ba4..db04f23fee 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2523,64 +2523,53 @@ chunks can be expressions as well as simple tokens.")
(license license:lgpl2.0+)))
(define-public guile-persist
- (let ((commit "b14927b0368af51c024560aee5f55724aee35233")
- (revision "1"))
- (package
- (name "guile-persist")
- (version (git-version "0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://gitlab.com/tampe/guile-persist")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0z5nf377wh8yj6n3sx2ddn4bdx1qrqnw899dlqjhg0q69qzil522"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Install .go files in the right place.
- (substitute* "Makefile.am"
- (("/ccache") "/site-ccache"))
- #t))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-prefix
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "src/Makefile.am"
- (("/usr/local/lib/guile")
- (string-append (assoc-ref outputs "out") "/lib/guile"))
- (("/usr/local/include/guile")
- (string-append (assoc-ref inputs "guile") "/include/guile"))
- (("-L/usr/local/lib")
- (string-append "-L" (assoc-ref inputs "guile") "/lib"))
- ;; Use canonical directory for go files.
- (("/ccache") "/site-ccache"))
- #t))
- (add-after 'unpack 'patch-library-reference
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "persist/persistance.scm"
- (("\"libguile-persist\"")
- (format #f "\"~a/lib/guile/2.2/extensions/libguile-persist\"" out)))
- #t))))))
- (inputs
- `(("guile" ,guile-2.2)))
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)))
- (home-page "https://gitlab.com/tampe/guile-persist")
- (synopsis "Persistence programming framework for Guile")
- (description
- "This is a serialization library for serializing objects like classes
+ (package
+ (name "guile-persist")
+ (version "1.2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/tampe/guile-persist")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19f8hqcax4v40858kx2j8fy1cvzc2djj99r0n17dy1xxmwa097qi"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-prefix
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "src/Makefile.am"
+ (("/usr/local/lib/guile")
+ (string-append (assoc-ref outputs "out") "/lib/guile"))
+ (("/usr/local/include/guile")
+ (string-append (assoc-ref inputs "guile") "/include/guile"))
+ (("-L/usr/local/lib")
+ (string-append "-L" (assoc-ref inputs "guile") "/lib")))
+ #t))
+ (add-after 'unpack 'patch-library-reference
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "persist/persistance.scm"
+ (("\"libguile-persist\"")
+ (format #f "\"~a/lib/guile/3.0/extensions/libguile-persist\"" out)))
+ #t))))))
+ (inputs
+ `(("guile" ,guile-3.0)))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://gitlab.com/tampe/guile-persist")
+ (synopsis "Persistence programming framework for Guile")
+ (description
+ "This is a serialization library for serializing objects like classes
and objects, closures and structs. This currently does not support
serializing continuations or delimited continuations.")
- (license license:lgpl2.0+))))
+ (license license:lgpl2.0+)))
(define-public python-on-guile
(let ((commit "00a51a23247f1edc4ae8eda72b30df5cd7d0015f")