summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-wm.scm
diff options
context:
space:
mode:
authorPierre-Moana Levesque <pierre.moana.levesque@gmail.com>2019-08-08 17:20:55 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-09-04 18:01:49 +0200
commite94b95473ea5dadea76be9763b7f8b34d400e863 (patch)
treed3f37d241015c7e34628e7aad7f66e3f2354851f /gnu/packages/guile-wm.scm
parent328a4c5bf1bc6f99515b18900811f724631bf91c (diff)
downloadguix-patches-e94b95473ea5dadea76be9763b7f8b34d400e863.tar
guix-patches-e94b95473ea5dadea76be9763b7f8b34d400e863.tar.gz
gnu: guile-wm: Fix cross-compilation.
* gnu/packages/guile-wm.scm (guile-wm): Add guile and guile-xcb to native-inputs.
Diffstat (limited to 'gnu/packages/guile-wm.scm')
-rw-r--r--gnu/packages/guile-wm.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/guile-wm.scm b/gnu/packages/guile-wm.scm
index 2955c06a0d..622fc560d9 100644
--- a/gnu/packages/guile-wm.scm
+++ b/gnu/packages/guile-wm.scm
@@ -172,7 +172,9 @@ dependencies.")
Type=Application~%"
,name ,synopsis %output))))
#t)))))
- (native-inputs `(("pkg-config" ,pkg-config)
+ (native-inputs `(("guile" ,guile-2.2)
+ ("guile-xcb" ,guile-xcb)
+ ("pkg-config" ,pkg-config)
("texinfo" ,texinfo)))
(inputs `(("guile" ,guile-2.2)
("guile-xcb" ,guile-xcb)))