summaryrefslogtreecommitdiff
path: root/gnu/packages/guile-wm.scm
diff options
context:
space:
mode:
authorng0 <ng0@n0.is>2017-12-04 22:14:58 +0000
committerKei Kebreau <kkebreau@posteo.net>2017-12-07 11:23:27 -0500
commit17acac51357c057c91506837fb39b1b0fea6d81e (patch)
treeb09d38eb5b712dc476b7e8eacfdbd27d97da0974 /gnu/packages/guile-wm.scm
parent3fb8041c0dbd26c18a611951af48ba34c951b59f (diff)
downloadguix-patches-17acac51357c057c91506837fb39b1b0fea6d81e.tar
guix-patches-17acac51357c057c91506837fb39b1b0fea6d81e.tar.gz
gnu: guile-xcb: Fix up indentation.
* gnu/packages/guile-wm.scm (guile-xcb): Fix up indentation. Signed-off-by: Kei Kebreau <kkebreau@posteo.net>
Diffstat (limited to 'gnu/packages/guile-wm.scm')
-rw-r--r--gnu/packages/guile-wm.scm65
1 files changed, 32 insertions, 33 deletions
diff --git a/gnu/packages/guile-wm.scm b/gnu/packages/guile-wm.scm
index 918761259f..5a21975fd4 100644
--- a/gnu/packages/guile-wm.scm
+++ b/gnu/packages/guile-wm.scm
@@ -34,41 +34,40 @@
(define-public guile-xcb
(let ((commit "db7d5a393cc37a56f66541b3f33938b40c6f35b3")
(revision "1"))
- (package
- (name "guile-xcb")
- (version (git-version "1.3" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/mwitmer/guile-xcb")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "16w4vgzbmnwih4bgfn8rw85ryfvzhc6hyly6bic9sd7hhc82rcnd"))))
- (build-system gnu-build-system)
- (arguments '(;; Parallel builds fail.
- #:parallel-build? #f
-
- #:configure-flags (list (string-append
- "--with-guile-site-dir="
- (assoc-ref %outputs "out")
- "/share/guile/site/2.2")
- (string-append
- "--with-guile-site-ccache-dir="
- (assoc-ref %outputs "out")
- "/share/guile/site/2.2"))))
- (native-inputs `(("pkg-config" ,pkg-config)
- ("texinfo" ,texinfo)))
- (inputs `(("guile" ,guile-2.2)
- ("xcb" ,xcb-proto)))
- (home-page "https://github.com/mwitmer/guile-xcb")
- (synopsis "XCB bindings for Guile")
- (description
- "Guile-XCB implements the XCB protocol and provides all the tools
+ (package
+ (name "guile-xcb")
+ (version (git-version "1.3" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mwitmer/guile-xcb")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16w4vgzbmnwih4bgfn8rw85ryfvzhc6hyly6bic9sd7hhc82rcnd"))))
+ (build-system gnu-build-system)
+ (arguments '(;; Parallel builds fail.
+ #:parallel-build? #f
+ #:configure-flags (list (string-append
+ "--with-guile-site-dir="
+ (assoc-ref %outputs "out")
+ "/share/guile/site/2.2")
+ (string-append
+ "--with-guile-site-ccache-dir="
+ (assoc-ref %outputs "out")
+ "/share/guile/site/2.2"))))
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("texinfo" ,texinfo)))
+ (inputs `(("guile" ,guile-2.2)
+ ("xcb" ,xcb-proto)))
+ (home-page "https://github.com/mwitmer/guile-xcb")
+ (synopsis "XCB bindings for Guile")
+ (description
+ "Guile-XCB implements the XCB protocol and provides all the tools
necessary to write X client code in Guile Scheme without any external
dependencies.")
- (license gpl3+))))
+ (license gpl3+))))
(define-public guile-wm
(let ((commit "f3c7b3be719f425ffb87265d34855a73366351be")