summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-15 20:11:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-15 20:11:35 +0100
commitf056553c6b8ffa36f4ce9fb1c3602a8f4b1de242 (patch)
tree80c815216a3717cf00b615c9cb8840c113eaf79f /gnu/packages/gtk.scm
parent2c9d34166983565120f831284df57a07e2edd2f9 (diff)
parent528b52390d216d8a8cd13dfcd1e6e40a6448e6c2 (diff)
downloadguix-patches-f056553c6b8ffa36f4ce9fb1c3602a8f4b1de242.tar
guix-patches-f056553c6b8ffa36f4ce9fb1c3602a8f4b1de242.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index c22ab0b9f1..3ed01d1967 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -44,6 +44,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
@@ -1729,7 +1730,7 @@ independent of your desktop environment, and supports global key bindings.")
(define-public yad
(package
(name "yad")
- (version "0.41.0")
+ (version "5.0")
(source
(origin
(method git-fetch)
@@ -1738,24 +1739,24 @@ independent of your desktop environment, and supports global key bindings.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1hkxiich898sbacpg3jflf6i8l4hkfnc0zh10rr376v0mnzbn6jn"))))
- (build-system gnu-build-system)
+ (base32 "07rd61hvilsxxrj7lf8c9k0a8glj07s48m7ya8d45030r90g3lvc"))))
+ (build-system glib-or-gtk-build-system)
(arguments
`(#:configure-flags
- '("--with-gtk=gtk3"
- "--enable-html"
- "--enable-gio"
- "--enable-spell"
- "--enable-icon-browser")
+ ;; Passing --enable-foo will silently disable foo if prerequisite
+ ;; inputs are missing, not abort the build as one might expect.
+ ;; ‘--enable-html’ adds a huge webkitgtk dependency. It was never
+ ;; present in the past and nobody complained.
+ '("--enable-icon-browser"
+ "--enable-spell") ; gspell checking support
#:phases
(modify-phases %standard-phases
- (replace 'bootstrap
+ (add-after 'bootstrap 'intltoolize
(lambda _
- (invoke "autoreconf" "-vif")
- (invoke "intltoolize" "--force" "--automake")
- #t)))))
+ (invoke "intltoolize" "--force" "--automake"))))))
(inputs
- `(("gtk+" ,gtk+)))
+ `(("gspell" ,gspell)
+ ("gtk+" ,gtk+)))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)