summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-02-04 09:40:49 +0100
committerLudovic Courtès <ludo@gnu.org>2021-02-04 09:40:49 +0100
commiteae865c134ebb8b7432572288e8721794d6a9b87 (patch)
tree289ecfffd0fad3deb6b323315daa38203ea0877b /gnu/packages/gtk.scm
parentd39c626cb96a939c994da7de619bc0786f871c33 (diff)
downloadguix-patches-eae865c134ebb8b7432572288e8721794d6a9b87.tar
guix-patches-eae865c134ebb8b7432572288e8721794d6a9b87.tar.gz
gnu: guile-cairo: Update to 1.11.2.
* gnu/packages/gtk.scm (guile-cairo): Update to 1.11.2. [source]: Remove now unnecessary bit from 'snippet'.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm12
1 files changed, 3 insertions, 9 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index cd6f9bd7ce..c6b4b6197a 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2015, 2017, 2018, 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
@@ -933,14 +933,14 @@ application suites.")
(define-public guile-cairo
(package
(name "guile-cairo")
- (version "1.11.1")
+ (version "1.11.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/guile-cairo/guile-cairo-"
version ".tar.gz"))
(sha256
(base32
- "1gc642r9ndsjhhmh9bl5cbd3dwvy4dpxwhr0zpsw43y9nmz37xpl"))
+ "0yx0844p61ljd4d3d63qrawiygiw6ks02fwv2cqx7nav5kfd8ck2"))
(modules '((guix build utils)))
(snippet
(begin
@@ -951,12 +951,6 @@ application suites.")
(string-append name "dir = " prefix
"/guile/site/@GUILE_EFFECTIVE_VERSION@"
suffix)))
-
- ;; Guile 2.x <libguile.h> used to pull in <string.h> and
- ;; other headers but this is no longer the case in 3.0.
- (substitute* (find-files "." "\\.[ch]$")
- (("^ *# *include.*libguile\\.h.*$")
- "#include <libguile.h>\n#include <string.h>\n"))
#t)))))
(build-system gnu-build-system)
(arguments