summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-09-01 23:44:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-09-01 23:44:26 +0300
commitc7a3926ee438263cfe03bea7e3cdd65c8585ce7a (patch)
treec7f60e5c89ae1f378f09d22e5d2de95dfc0a2152 /gnu/packages/gtk.scm
parentf91270bf0ab5b7f9dd54e08ebd45a6b2be5ec46e (diff)
downloadguix-patches-c7a3926ee438263cfe03bea7e3cdd65c8585ce7a.tar
guix-patches-c7a3926ee438263cfe03bea7e3cdd65c8585ce7a.tar.gz
gnu: guile-cairo: Update to 1.11.1.
* gnu/packages/gtk.scm (guile-cairo): Update to 1.11.1. [arguments]: Add make-flag to hide guild warnings.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 63980a6b04..ff8547d00b 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -916,14 +916,14 @@ application suites.")
(define-public guile-cairo
(package
(name "guile-cairo")
- (version "1.10.0")
+ (version "1.11.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/guile-cairo/guile-cairo-"
version ".tar.gz"))
(sha256
(base32
- "0p6xrhf2k6n5dybn88050za7h90gnd7534n62l53vsca187pwgdf"))
+ "1gc642r9ndsjhhmh9bl5cbd3dwvy4dpxwhr0zpsw43y9nmz37xpl"))
(modules '((guix build utils)))
(snippet
(begin
@@ -945,7 +945,8 @@ application suites.")
(arguments
;; Uses of 'scm_t_uint8' & co. are deprecated; don't stop the build
;; because of them.
- '(#:configure-flags '("--disable-Werror")))
+ '(#:configure-flags '("--disable-Werror")
+ #:make-flags '("GUILE_AUTO_COMPILE=0"))) ; to prevent guild warnings
(inputs
`(("guile-lib" ,guile-lib)
("expat" ,expat)