summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 11:08:24 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:43:38 -0400
commitb1ab7a5a33f2940e2e401d80783345eb2ae643b2 (patch)
treeac9a0c8121ea874a4d36b312064f381954a28bb8 /gnu/packages/gtk.scm
parent2539bc5cab368ad98fdc88ccb77a8a790bbb8cde (diff)
downloadguix-patches-b1ab7a5a33f2940e2e401d80783345eb2ae643b2.tar
guix-patches-b1ab7a5a33f2940e2e401d80783345eb2ae643b2.tar.gz
gnu: gdk-pixbuf+svg: Correct package definition to include changes from gdk-pixbuf.
* gnu/packages/gtk.scm (gdk-pixbuf+svg) [arguments]: Modify. [synopsis]: Modify. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index c97bc66acb..582a096c12 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -659,10 +659,9 @@ scaled, composited, modified, saved, or rendered.")
`(("librsvg" ,librsvg)
,@(package-inputs gdk-pixbuf)))
(arguments
- '(#:configure-flags '("-Dinstalled-tests=false")
- #:tests? #f ; tested by the gdk-pixbuf package already
- #:phases
- (modify-phases %standard-phases
+ (substitute-keyword-arguments (package-arguments gdk-pixbuf)
+ ((#:phases phases)
+ `(modify-phases ,phases
(add-after 'install 'register-svg-loader
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -676,9 +675,8 @@ scaled, composited, modified, saved, or rendered.")
(apply invoke
gdk-pixbuf-query-loaders
"--update-cache"
- loaders)))))))
- (synopsis
- "GNOME image loading and manipulation library, with SVG support")))
+ loaders))))))))
+ (synopsis "Image loading library, with SVG support")))
(define-public at-spi2-core
(package