summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-25 16:08:23 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-09-20 11:15:10 +0000
commitaacaa222d1646a99343d8f59b2e87f34e27b75ae (patch)
tree74f9cf7c49d240f70d637435aaa8e6b385a9b641 /gnu/packages/gtk.scm
parentd1737d44e6a6c25e4f090b4c6a68b3b1736d6bec (diff)
downloadguix-patches-aacaa222d1646a99343d8f59b2e87f34e27b75ae.tar
guix-patches-aacaa222d1646a99343d8f59b2e87f34e27b75ae.tar.gz
gnu: at-spi2-atk: Don't compile tests when cross-compiling.
* gnu/packages/gtk.scm (at-spi2-atk)[arguments]<#:configure-flags>: Set tests=false when cross-compiling.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 95631c6688..9868b11e48 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -856,6 +856,10 @@ is part of the GNOME accessibility project.")
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ ;; Compiling tests requires "libxml2" to be in 'inputs'.
+ ,@(if (%current-target-system)
+ `(#:configure-flags '("-Dtests=false"))
+ '())
#:phases
(modify-phases %standard-phases
(replace 'check