summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-15 18:56:47 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-25 17:52:36 +0200
commita682fea916b9f3ff101a76273aa754e11d53244d (patch)
tree21643a3ecab782ddaafbe21b65efabcfa6347262 /gnu/packages/gtk.scm
parent52cc6394033546406b81c146d38104c1d80dc68f (diff)
downloadguix-patches-a682fea916b9f3ff101a76273aa754e11d53244d.tar
guix-patches-a682fea916b9f3ff101a76273aa754e11d53244d.tar.gz
gnu: gs-font: Rename to 'font-ghostscript'.
According to (guix)Fonts, font package names must be prefixed with 'font-'. Adjust 'gs-fonts' to follow this convention. * gnu/packages/fontutils.scm (gs-fonts)[name]: Set to "font-ghostscript". (gs-fonts): Rename variable to 'font-ghostscript'. (gs-fonts): Add deprecated package. * gnu/packages/ghostscript.scm (ghostscript)[arguments]<#:configure-flags>: Replace 'gs-fonts' with 'font-ghostscript'. (ghostscript)[inputs]: Likewise. * gnu/packages/fontutils.scm (fontconfig)[inputs]: Likewise. * gnu/packages/gtk.scm (pango-1.42)[arguments]{disable-layout-test}: Likewise. * gnu/packages/imagemagick.scm (graphicsmagick)[arguments]{configure-flags}: Likewise. (graphicsmagick)[inputs]: Likewise. * gnu/packages/mp3.scm (ripperx)[propagated-inputs]: Likewise. * doc/guix.texi (X11 Fonts): Likewise. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 21e27d8597..bf4ce3b7b6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -402,10 +402,11 @@ handling for GTK+-2.x.")
(add-after 'configure 'disable-layout-test
(lambda _
;; This test requires that fontconfig uses bitmap fonts
- ;; such as "gs-fonts"; however providing such a package
- ;; alone is not enough, as the requirement comes from
- ;; deeper in the font stack. Since this version of Pango
- ;; is only used for librsvg, simply disable the test.
+ ;; such as "font-ghostscript"; however providing such a
+ ;; package alone is not enough, as the requirement comes
+ ;; from deeper in the font stack. Since this version of
+ ;; Pango is only used for librsvg, simply disable the
+ ;; test.
(substitute* "tests/Makefile"
(("test-layout\\$\\(EXEEXT\\)") ""))
#t)))))))