summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorYoav Marco <yoavm448@gmail.com>2021-03-12 03:26:20 +0200
committerLudovic Courtès <ludo@gnu.org>2021-03-19 13:57:00 +0100
commit9991b5e3e572fcc6ede775e298949263541d05fc (patch)
tree9907cd95f413be0a547bd54b5b43f8c0ac2e91e4 /gnu/packages/gtk.scm
parentb6f0c9920146c3d3d125b96ea18226d691c549c0 (diff)
downloadguix-patches-9991b5e3e572fcc6ede775e298949263541d05fc.tar
guix-patches-9991b5e3e572fcc6ede775e298949263541d05fc.tar.gz
gnu: Add dragon-drop.
* gnu/packages/gtk.scm (dragon-drop): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 9fc4967181..5b1c4481fd 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -2082,6 +2082,53 @@ shell scripts. Example of how to use @code{yad} can be consulted at
@url{https://sourceforge.net/p/yad-dialog/wiki/browse_pages/}.")
(license license:gpl3+)))
+(define-public dragon-drop
+ (package
+ (name "dragon-drop")
+ (version "1.1.1")
+ (source (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mwh/dragon")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fgzz39007fdjwq72scp0qygp2v3zc5f1xkm0sxaa8zxm25g1bra"))))
+ (build-system gnu-build-system)
+ (inputs `(("gtk+" ,gtk+)))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:tests? #f ; no check
+ #:make-flags
+ (list (string-append "CC=" ,(cc-for-target))
+ ;; makefile uses PREFIX for the binary location
+ (string-append "PREFIX=" (assoc-ref %outputs "out")
+ "/bin"))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)))) ; no configure script
+ (synopsis "Drag and drop source/target for X")
+ (description
+ "Dragon is a lightweight drag-and-drop source for X where you can run:
+
+@example
+dragon file.tar.gz
+@end example
+
+to get a window with just that file in it, ready to be dragged where you need it.
+What if you need to drag into something? Using:
+
+@example
+dragon --target
+@end example
+
+you get a window you can drag files and text into. Dropped items are
+printed to standard output.")
+ (home-page "https://github.com/mwh/dragon")
+ (license license:gpl3+)))
+
(define-public libdbusmenu
(package
(name "libdbusmenu")