summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-16 21:45:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-17 03:37:48 +0100
commit853556831b40ae95f67fd411a19bb9a88bd4977c (patch)
treea747d6c7b69832cfd37f6b347e1768f7fed2e897 /gnu/packages/gtk.scm
parent4f4b37dfdf99531458df79b558b453defe9b4f17 (diff)
downloadguix-patches-853556831b40ae95f67fd411a19bb9a88bd4977c.tar
guix-patches-853556831b40ae95f67fd411a19bb9a88bd4977c.tar.gz
gnu: clipit: Update to 1.4.4.
* gnu/packages/gtk.scm (clipit): Update to 1.4.4. [source]: Use GIT-FETCH and GIT-FILE-NAME. [native-inputs]: Add autoconf and automake.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm23
1 files changed, 13 insertions, 10 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 9d9750cde1..fb5c178d53 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1591,18 +1591,21 @@ misspelled words in a GtkTextView widget.")
(define-public clipit
(package
(name "clipit")
- (version "1.4.2")
- (source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/downloads/ClipIt/clipit-"
- version ".tar.gz"))
- (sha256
- (base32
- "0jrwn8qfgb15rwspdp1p8hb1nc0ngmpvgr87d4k3lhlvqg2cfqva"))))
+ (version "1.4.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/CristianHenzel/ClipIt.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05xi29v2y0rvb33fmvrz7r9j4l858qj7ngwd7dp4pzpkkaybjln0"))))
(build-system gnu-build-system)
(native-inputs
- `(("intltool" ,intltool)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("intltool" ,intltool)
("pkg-config" ,pkg-config)))
(inputs
`(("gtk+" ,gtk+-2)))