summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-02 22:35:05 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:19 -0500
commit831c08d8f263f476e0293f8a5422e7314a159c91 (patch)
tree7d2187902387e1973c73fe7a1015013c087dfd85 /gnu/packages/gtk.scm
parent20e3dd052d7e4f59273e3646d3533d43c87c30b0 (diff)
downloadguix-patches-831c08d8f263f476e0293f8a5422e7314a159c91.tar
guix-patches-831c08d8f263f476e0293f8a5422e7314a159c91.tar.gz
gnu: gdk-pixbuf: Add a search path for the loaders cache file.
Fixes <https://issues.guix.gnu.org/50957>. The previous commit added a profile hook to compute a gdk-pixbuf loaders cache file. This change enables gdk-pixbuf to make use of it. * gnu/packages/gtk.scm (gdk-pixbuf)[native-search-paths]: Add a search path specification to set the GDK_PIXBUF_MODULE_FILE environment variable.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 8c3d554ddd..005d2b8399 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -697,6 +697,14 @@ highlighting and other features typical of a source code editor.")
("perl" ,perl)
("pkg-config" ,pkg-config)
("xsltproc" ,libxslt)))
+ (native-search-paths
+ ;; This file is produced by the gdk-pixbuf-loaders-cache-file
+ ;; profile hook.
+ (list (search-path-specification
+ (variable "GDK_PIXBUF_MODULE_FILE")
+ (files (list %gdk-pixbuf-loaders-cache-file))
+ (separator #f) ;single valued
+ (file-type 'regular))))
(synopsis "Image loading library")
(description "GdkPixbuf is a library that loads image data in various
formats and stores it as linear buffers in memory. The buffers can then be