summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-08 14:10:54 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-08 14:12:05 +0200
commit5f919605e94b12d7f56656a30f66f205c24cde98 (patch)
tree679caa2a5a3aab10b2b2279608136952ed13be67 /gnu/packages/gtk.scm
parent7a9f4822c0c431c25071977b68ab79d152887ec3 (diff)
downloadguix-patches-5f919605e94b12d7f56656a30f66f205c24cde98.tar
guix-patches-5f919605e94b12d7f56656a30f66f205c24cde98.tar.gz
gnu: libdatrie: Run tests sequentially.
Fixes <https://bugs.gnu.org/49463>. * gnu/packages/gtk.scm (libdatrie)[arguments]: Add #:parallel-tests?.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index dc0089cbd9..f8961def92 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -280,7 +280,11 @@ output. Experimental backends include OpenGL, BeOS, OS/2, and DirectFB.")
(list
(string-append "--with-html-docdir="
(assoc-ref %outputs "doc")
- "/share/doc/datrie/html"))))
+ "/share/doc/datrie/html"))
+
+ ;; Several tests refer to the 'test.tri' file, leading to race
+ ;; conditions when running tests in parallel.
+ #:parallel-tests? #f))
(native-inputs
`(("doxygen" ,doxygen)
("pkg-config" ,pkg-config)))