summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-03-05 21:36:25 +0800
committerLudovic Courtès <ludo@gnu.org>2022-04-04 22:58:02 +0200
commit4df7fe14ff47d8858f5c7fc7036b0bb1cc662a86 (patch)
tree29200fca841deb9b39e1b144aff454a24026aa60 /gnu/packages/gtk.scm
parent345f79b2cf02ecd187a1e3c922f685f3fc58bf2e (diff)
downloadguix-patches-4df7fe14ff47d8858f5c7fc7036b0bb1cc662a86.tar
guix-patches-4df7fe14ff47d8858f5c7fc7036b0bb1cc662a86.tar.gz
gnu: pango 1.50: Add version 1.50.4.
* gnu/packages/gtk.scm(pango-next): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0abe22d637..61cc7ce1cb 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -29,6 +29,7 @@
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
+;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -409,6 +410,22 @@ handling for GTK+-2.x.")
(home-page "https://pango.gnome.org/")
(license license:lgpl2.0+)))
+;; TODO: Make this the default package in next release cycle.
+(define-public pango-next
+ (package
+ (inherit pango)
+ (name "pango")
+ (version "1.50.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/pango/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (patches (search-patches "pango-skip-libthai-test.patch"))
+ (sha256
+ (base32
+ "0qn1a7ccs3p5vc6swbqm6hdzka879l0gp9220lq4bcf2gpl67bgl"))))))
+
(define-public pango-1.42
(package
(inherit pango)