summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2021-10-12 14:10:18 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:30 -0500
commit4b4e35a771cbcc7b72d28e9a4c6a0d6de2000175 (patch)
treef793bd1018ea477a04065ea464671d2620d1e995 /gnu/packages/gtk.scm
parentaf8b03b4e26ec1e50559062d3115398eb6a63c2c (diff)
downloadguix-patches-4b4e35a771cbcc7b72d28e9a4c6a0d6de2000175.tar
guix-patches-4b4e35a771cbcc7b72d28e9a4c6a0d6de2000175.tar.gz
gnu: gtk+-2: Fix ‘builder’ test.
The signal callbacks in the ‘builder’ testcase have wrong prototypes. This causes it to fail the “/Builder/Signal Autoconnect” test on powerpc64le-linux. Solve the problem by backporting the upstream fix that was applied to GTK+ 3.0. * gnu/packages/patches/gtk2-fix-builder-test.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/gtk.scm (gtk+-2): Use it. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 3ebd87ee2d..5dfdaae7e4 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -916,7 +916,8 @@ is part of the GNOME accessibility project.")
"1nn6kks1zyvb5xikr9y2k7r9bwjy1g4b0m0s66532bclymbwfamc"))
(patches (search-patches "gtk2-respect-GUIX_GTK2_PATH.patch"
"gtk2-respect-GUIX_GTK2_IM_MODULE_FILE.patch"
- "gtk2-theme-paths.patch"))))
+ "gtk2-theme-paths.patch"
+ "gtk2-fix-builder-test.patch"))))
(build-system gnu-build-system)
(outputs '("out" "bin" "doc" "debug"))
(propagated-inputs