summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-01 00:03:36 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-01 01:32:33 +0200
commit3eed550072d6f71eff20de269d313fc1dfe3e332 (patch)
treebb4be7b8f983c28d17df54a475dc3eb3263af678 /gnu/packages/gtk.scm
parent571fb008a576378883c053be186d2c620290ea39 (diff)
downloadguix-patches-3eed550072d6f71eff20de269d313fc1dfe3e332.tar
guix-patches-3eed550072d6f71eff20de269d313fc1dfe3e332.tar.gz
gnu: Remove gtk+/fixed.
The merge preceding this commit ignored the replacement part of commit bc91562939ee002e84c95d13c907482b6d1e9339. This commit removes the remaining bits, as the patch is already included in GTK3 since version 3.24.3. * gnu/packages/patches/gtk3-fix-deprecation-macro-use.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/gtk.scm (gtk+/fixed): Remove variable.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 7527abbbac..6e63ca6614 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -822,18 +822,6 @@ application suites.")
(variable "GUIX_GTK3_PATH")
(files '("lib/gtk-3.0")))))))
-;; Fixes a bug in Gtk that causes crashes in IceCat and Emacs.
-;; See <https://bugs.gnu.org/34454>, <https://bugs.gnu.org/34658>,
-;; and <https://gitlab.gnome.org/GNOME/gtk/issues/1523>.
-(define gtk+/fixed
- (package
- (inherit gtk+)
- (source (origin
- (inherit (package-source gtk+))
- (patches
- (cons (search-patch "gtk3-fix-deprecation-macro-use.patch")
- (origin-patches (package-source gtk+))))))))
-
;;;
;;; Guile bindings.
;;;