summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-14 19:39:09 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-14 19:39:09 +0100
commit3ea5a8ee4789c08b4ecdcff94b7bd30fee475601 (patch)
tree3def22f53847c7234aba99199c63e95eb6c0d6fb /gnu/packages/gtk.scm
parent5254f17eebeef1690617ea0c17fc454ca91242bc (diff)
downloadguix-patches-3ea5a8ee4789c08b4ecdcff94b7bd30fee475601.tar
guix-patches-3ea5a8ee4789c08b4ecdcff94b7bd30fee475601.tar.gz
gnu: at-spi2-atk: Update to 2.32.0.
* gnu/packages/gtk.scm (at-spi2-atk): Update to 2.32.0. [build-system]: Change to MESON-BUILD-SYSTEM. [arguments]: Adjust test invokation. [native-inputs]: Add LIBXML2.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b62a4aaa27..c790bd8e40 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -624,7 +624,7 @@ is part of the GNOME accessibility project.")
(define-public at-spi2-atk
(package
(name "at-spi2-atk")
- (version "2.26.2")
+ (version "2.32.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -632,8 +632,8 @@ is part of the GNOME accessibility project.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0vkan52ab9vrkknnv8y4f1cspk8x7xd10qx92xk9ys71p851z2b1"))))
- (build-system gnu-build-system)
+ "0p54wx6f6q7s8w0b1j0sgw87pikllp79q5g3lfiwqazs779ycl8b"))))
+ (build-system meson-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
@@ -641,14 +641,16 @@ is part of the GNOME accessibility project.")
;; Run test-suite under a dbus session.
(lambda _
(setenv "DBUS_FATAL_WARNINGS" "0")
- (invoke "dbus-launch" "make" "check"))))))
+ (invoke "dbus-launch" "meson" "test"))))))
(propagated-inputs
`(("at-spi2-core" ,at-spi2-core))) ; required by atk-bridge-2.0.pc
(inputs
`(("atk" ,atk)))
(native-inputs
- `(("dbus" ,dbus) ; for testing
- ("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ;; For tests.
+ ("dbus" ,dbus)
+ ("libxml2" ,libxml2)))
(synopsis "Assistive Technology Service Provider Interface, ATK bindings")
(description
"The Assistive Technology Service Provider Interface