summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-23 20:07:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-24 13:25:27 +0200
commit2ea3bfe7cb0e7a080fb4797853cca5a5e4e75b38 (patch)
treeaec52893fbc84817dfca714508419614518d7ea6 /gnu/packages/gtk.scm
parent89512e1b30b549dd47db21fcb015c2c0ec540aaf (diff)
downloadguix-patches-2ea3bfe7cb0e7a080fb4797853cca5a5e4e75b38.tar
guix-patches-2ea3bfe7cb0e7a080fb4797853cca5a5e4e75b38.tar.gz
gnu: Add volumeicon.
* gnu/packages/gtk.scm (volumeicon): New public variable.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 9e7272062f..2776bd31a3 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -68,6 +68,7 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages libffi)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
@@ -1706,6 +1707,38 @@ viewing and manipulating 2 dimensional tabular data in a manner similar to many
popular spread sheet programs.")
(license license:gpl3+)))
+(define-public volumeicon
+ (package
+ (name "volumeicon")
+ (version "0.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://nullwise.com/files/volumeicon/volumeicon-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "182xl2w8syv6ky2h2bc9imc6ap8pzh0p7rp63hh8nw0xm38c3f14"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--enable-notify"))) ; optional libnotify support
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("gtk+" ,gtk+)
+ ("libnotify" ,libnotify)))
+ (home-page "http://nullwise.com/volumeicon.html")
+ (synopsis "System tray volume applet")
+ (description
+ "Volume Icon is a volume indicator and control applet for @acronym{the
+Advanced Linux Sound Architecture, ALSA}. It sits in the system tray,
+independent of your desktop environment, and supports global key bindings.")
+ (license (list license:expat ; src/{bind.c,keybinder.h}
+ license:isc ; src/alsa_volume_mapping.c
+ license:gpl3)))) ; the rest & combined work
+
(define-public yad
(package
(name "yad")