summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-01 20:02:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-01 20:16:34 +0100
commit2223cbdefa43cf16a348a847769b5876738040d3 (patch)
tree445060226606e1fef6e2366a34bcbff1f7a76324 /gnu/packages/gtk.scm
parentc688e314dce7da093366fd782aa1306899842c43 (diff)
downloadguix-patches-2223cbdefa43cf16a348a847769b5876738040d3.tar
guix-patches-2223cbdefa43cf16a348a847769b5876738040d3.tar.gz
gnu: yad: Update to 5.0.
* gnu/packages/gtk.scm (yad): Update to 5.0. [build-system]: Use Glib-or-Gtk build system. [arguments]: Remove obsolete or ineffective #:configure-flags. Use the default ‘bootstrap’ phase followed by an ‘intltoolize’ one. [inputs]: Add gspell.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index b0dd0c6cc6..436018efdb 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -44,6 +44,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
#:use-module (guix build-system perl)
@@ -1737,7 +1738,7 @@ independent of your desktop environment, and supports global key bindings.")
(define-public yad
(package
(name "yad")
- (version "0.41.0")
+ (version "5.0")
(source
(origin
(method git-fetch)
@@ -1746,24 +1747,24 @@ independent of your desktop environment, and supports global key bindings.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1hkxiich898sbacpg3jflf6i8l4hkfnc0zh10rr376v0mnzbn6jn"))))
- (build-system gnu-build-system)
+ (base32 "07rd61hvilsxxrj7lf8c9k0a8glj07s48m7ya8d45030r90g3lvc"))))
+ (build-system glib-or-gtk-build-system)
(arguments
`(#:configure-flags
- '("--with-gtk=gtk3"
- "--enable-html"
- "--enable-gio"
- "--enable-spell"
- "--enable-icon-browser")
+ ;; Passing --enable-foo will silently disable foo if prerequisite
+ ;; inputs are missing, not abort the build as one might expect.
+ ;; ‘--enable-html’ adds a huge webkitgtk dependency. It was never
+ ;; present in the past and nobody complained.
+ '("--enable-icon-browser"
+ "--enable-spell") ; gspell checking support
#:phases
(modify-phases %standard-phases
- (replace 'bootstrap
+ (add-after 'bootstrap 'intltoolize
(lambda _
- (invoke "autoreconf" "-vif")
- (invoke "intltoolize" "--force" "--automake")
- #t)))))
+ (invoke "intltoolize" "--force" "--automake"))))))
(inputs
- `(("gtk+" ,gtk+)))
+ `(("gspell" ,gspell)
+ ("gtk+" ,gtk+)))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)