summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorJaft <jaft.r@outlook.com>2021-12-17 09:05:02 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-17 09:05:02 +0100
commit21d1bffb61bbaa3e2c898bb51fd484f44f0344ff (patch)
tree980cfb3e3d8ebefadce0de5269eb347e5b50b69f /gnu/packages/gtk.scm
parent1028b82530375275c631d8434943e9eee60e4ae3 (diff)
downloadguix-patches-21d1bffb61bbaa3e2c898bb51fd484f44f0344ff.tar
guix-patches-21d1bffb61bbaa3e2c898bb51fd484f44f0344ff.tar.gz
gnu: Add pnmixer.
* gnu/packages/gtk.scm (pnmixer): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a7e5d10e10..a5b804d848 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -28,6 +28,7 @@
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2021 Wamm K. D. <jaft.r@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -52,6 +53,7 @@
#:use-module (guix download)
#:use-module (guix git-download)
#:use-module ((guix build utils) #:select (alist-replace))
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
@@ -2454,6 +2456,40 @@ viewing and manipulating 2 dimensional tabular data in a manner similar to many
popular spread sheet programs.")
(license license:gpl3+)))
+(define-public pnmixer
+ (package
+ (name "pnmixer")
+ (version "0.7.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nicklan/pnmixer/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0416pa933ddf4b7ph9zxhk5jppkk7ppcq1aqph6xsrfnka4yb148"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ;no check target
+ (native-inputs
+ (list gettext-minimal pkg-config))
+ (inputs
+ (list alsa-lib glib gtk+ libnotify libx11))
+ (home-page "https://github.com/nicklan/pnmixer/")
+ (synopsis "Simple mixer application designed to run in system tray")
+ (description
+ "PNMixer is a simple mixer application designed to run in system tray.
+It integrates nicely into desktop environments that don't have a panel that
+supports applets and therefore can't run a mixer applet. In particular, it's
+been used quite a lot with fbpanel and tint2 but should run fine in any system
+tray.
+
+PNMixer is designed to work on systems that use ALSA for sound management.
+Any other sound driver like OSS or FFADO are, currently, not supported. There
+is no official PulseAudio support, at the moment, but it seems that PNMixer
+behaves quite well anyway when PA is running.")
+ (license license:gpl3)))
+
(define-public volumeicon
(package
(name "volumeicon")