summaryrefslogtreecommitdiff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-18 16:05:21 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-18 19:50:01 +0200
commit0e47fcced442d8e7c1b05184fdc1c14f10ed04ec (patch)
tree4ae844bc0ec3c670f8697bdc24362c122fa718ad /gnu/packages/gtk.scm
parente4b70bc55a538569465bcedee19d1f2607308e65 (diff)
parent8b1bde7bb3936a64244824500ffe60f123704437 (diff)
downloadguix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar
guix-patches-0e47fcced442d8e7c1b05184fdc1c14f10ed04ec.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm69
1 files changed, 68 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a90db08f6e..5e9c9feabe 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -87,6 +87,7 @@
#:use-module (gnu packages man)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages perl-check)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
@@ -1844,7 +1845,7 @@ write GNOME applications.")
(native-inputs
`(("perl-extutils-depends" ,perl-extutils-depends)
("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)))
- (inputs
+ (propagated-inputs
`(("cairo" ,cairo)))
(home-page "https://metacpan.org/release/Cairo")
(synopsis "Perl interface to the cairo 2d vector graphics library")
@@ -1853,6 +1854,30 @@ cairo. It supports multiple output targets, including PNG, PDF and SVG. Cairo
produces identical output on all those targets.")
(license license:lgpl2.1+)))
+(define-public perl-cairo-gobject
+ (package
+ (name "perl-cairo-gobject")
+ (version "1.005")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/X/XA/XAOC/"
+ "Cairo-GObject-" version ".tar.gz"))
+ (sha256
+ (base32 "0l2wcz77ndmbgvxx34gdm919a3dxh9fixqr47p50n78ysx2692cd"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-extutils-depends" ,perl-extutils-depends)
+ ("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)))
+ (propagated-inputs
+ `(("perl-cairo" ,perl-cairo)
+ ("perl-glib" ,perl-glib)))
+ (home-page "https://metacpan.org/dist/Cairo-GObject")
+ (synopsis "Integrate Cairo into the Glib type system")
+ (description "Cairo::GObject registers Cairo's types with Glib's type systems,
+so that they can be used normally in signals and properties.")
+ (license license:lgpl2.1+)))
+
(define-public perl-gtk2
(package
(name "perl-gtk2")
@@ -1890,6 +1915,48 @@ object-oriented way, freeing you from the casting and memory management in C,
yet remaining very close in spirit to original API.")
(license license:lgpl2.1+)))
+(define-public perl-gtk3
+ (package
+ (name "perl-gtk3")
+ (version "0.038")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/X/XA/XAOC/Gtk3-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1k3sfcvxxx7ir7ail7w1lkmr4np0k3criljzw5wir63lmbr4pp3h"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 +extension GLX &")
+ (setenv "DISPLAY" ":1"))))))
+ (native-inputs
+ `(("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("gtk+:bin" ,gtk+ "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("perl-extutils-depends" ,perl-extutils-depends)
+ ("perl-extutils-pkgconfig" ,perl-extutils-pkgconfig)
+ ("perl-test-simple" ,perl-test-simple)
+ ("xorg-server" ,xorg-server-for-tests)))
+ (propagated-inputs
+ `(("gtk+" ,gtk+)
+ ("perl-cairo-gobject" ,perl-cairo-gobject)
+ ("perl-carp" ,perl-carp)
+ ("perl-exporter" ,perl-exporter)
+ ("perl-glib-object-introspection" ,perl-glib-object-introspection)))
+ (home-page "https://metacpan.org/dist/Gtk3")
+ (synopsis "Perl interface to the 3.x series of the gtk+ toolkit")
+ (description "Perl bindings to the 3.x series of the gtk+ toolkit.
+This module allows you to write graphical user interfaces in a Perlish and
+object-oriented way, freeing you from the casting and memory management in C,
+yet remaining very close in spirit to original API.")
+ (license license:lgpl2.1+)))
+
(define-public perl-pango
(package
(name "perl-pango")