summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-01-21 21:12:48 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-21 21:29:06 +0100
commite003b7591f6c0cff8aeaf0d2063fb8a038a068a1 (patch)
tree7052ef5c7bd05fdaad4bf093b592f2aa104a15bc /gnu/packages/gstreamer.scm
parent0025a1d31eb1d0aedb9e13a60ba36b9a13b67461 (diff)
downloadguix-patches-e003b7591f6c0cff8aeaf0d2063fb8a038a068a1.tar
guix-patches-e003b7591f6c0cff8aeaf0d2063fb8a038a068a1.tar.gz
gnu: gst-plugins-bad: Disable failing test on armhf-linux.
* gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Add phase when building for armhf-linux.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index ce4eb707e7..7ff78b2a77 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -313,8 +313,19 @@ developers consider to have good quality code and correct functionality.")
"0x0y0hm0ga3zqi5q4090hw5sjh59y1ry9ak16qsaascm72i7mjzi"))))
(build-system meson-build-system)
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
+ ,@(if (string-prefix? "arm" (or (%current-target-system)
+ (%current-system)))
+ ;; Disable test that fails on ARMv7.
+ ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/issues/1188
+ `((add-after 'unpack 'disable-asfmux-test
+ (lambda _
+ (substitute* "tests/check/meson.build"
+ (("\\[\\['elements/asfmux\\.c'\\]\\],")
+ ""))
+ #t)))
+ '())
(add-after 'unpack 'disable-failing-test
(lambda _
;; FIXME: Why is this failing.