summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-17 20:47:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-17 20:47:11 +0200
commitd02bb02f7d833ad371c53c346b6cb77f01377cf4 (patch)
tree9506f04a7fde2f3b264ba1d2a9012085e1f72b72 /gnu/packages/gstreamer.scm
parentfb3ff265cd8c6b4c6160f94240dc8932097e637b (diff)
parentacce0a474c1493ab18912bc46285248e4ccb0314 (diff)
downloadguix-patches-d02bb02f7d833ad371c53c346b6cb77f01377cf4.tar
guix-patches-d02bb02f7d833ad371c53c346b6cb77f01377cf4.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 21acd9f150..f43a0fc2f5 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -227,6 +227,7 @@ for the GStreamer multimedia library.")
("gdk-pixbuf" ,gdk-pixbuf)
("gst-plugins-base" ,gst-plugins-base)
("jack" ,jack-1)
+ ("lame" ,lame)
("libavc1394" ,libavc1394)
("libcaca" ,libcaca)
("libdv" ,libdv)
@@ -236,10 +237,12 @@ for the GStreamer multimedia library.")
("libshout" ,libshout)
("libsoup" ,libsoup)
("libvpx" ,libvpx)
+ ("mpg123" ,mpg123)
("orc" ,orc)
("pulseaudio" ,pulseaudio)
("speex" ,speex)
("taglib" ,taglib)
+ ("twolame" ,twolame)
("wavpack" ,wavpack)))
(native-inputs
`(("glib:bin" ,glib "bin")
@@ -320,7 +323,6 @@ developers consider to have good quality code and correct functionality.")
("libxml2" ,libxml2)
("lrdf" ,lrdf)
("mesa" ,mesa)
- ("mpg123" ,mpg123)
("neon" ,neon)
("openal" ,openal)
("openexr" ,openexr)
@@ -357,13 +359,10 @@ par compared to the rest.")
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
("liba52" ,liba52)
- ("lame" ,lame)
("libcdio" ,libcdio)
- ("twolame" ,twolame)
("libmpeg2" ,libmpeg2)
("libdvdread" ,libdvdread)
("libx264" ,libx264)
- ("mpg123" ,mpg123)
;; TODO:
;; * opencore-amr (for the AMR-NB decoder and encoder and the
;; AMR-WB decoder) <http://sourceforge.net/projects/opencore-amr/>