summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-04-12 11:36:12 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:19 -0500
commitb7e3912febbd609d3b8e5d8981b18b8ca7c99cdb (patch)
tree080f9a80f7ec6c83dcb4f9564dfd8153ab3f8976 /gnu/packages/gstreamer.scm
parent5219a10b33cd983170869edf860301d916dd2a43 (diff)
downloadguix-patches-b7e3912febbd609d3b8e5d8981b18b8ca7c99cdb.tar
guix-patches-b7e3912febbd609d3b8e5d8981b18b8ca7c99cdb.tar.gz
gnu: gst-plugins-bad: Update to 1.18.4.
* gnu/packages/gstreamer.scm (gst-plugins-bad)[version]: Update to 1.18.4. [arguments](glib-or-gtk): New argument. [phases](adjust-tests): Disable line21. [phases](pre-check): New phase. [propagated-inputs]: Add gstreamer. [native-inputs]: Add gettext-minimal, gsettings-desktop-schemas, perl and xorg-server-for-tests. Replace python with python-wrapper. Co-authored-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm31
1 files changed, 25 insertions, 6 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index fbe27da548..f17bc23180 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -711,7 +711,7 @@ model to base your own plug-in on, here it is.")
(define-public gst-plugins-bad
(package
(name "gst-plugins-bad")
- (version "1.18.2")
+ (version "1.18.4")
(source (origin
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/src/"
@@ -719,7 +719,7 @@ model to base your own plug-in on, here it is.")
(patches (search-patches "gst-plugins-bad-fix-overflow.patch"))
(sha256
(base32
- "06ildd4rl6cynirv3p00d2ddf5is9svj4i7mkahldzhq24pq5mca"))
+ "0py8k4pbalm9mxkpjbjxis0gp7g74wg5g4yax5q8rccmany0ds3l"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -728,6 +728,7 @@ model to base your own plug-in on, here it is.")
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dsctp-internal-usrsctp=disabled")
+ #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:phases
(modify-phases %standard-phases
,@%common-gstreamer-phases
@@ -755,21 +756,39 @@ model to base your own plug-in on, here it is.")
;; FIXME: Why is this failing.
((".*elements/dash_mpd\\.c.*") "")
+ ((".*elements/line21\\.c.*") "")
;; These tests are flaky and occasionally time out:
;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
((".*elements/curlhttpsrc\\.c.*") "")
;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/1412
((".*elements/dtls\\.c.*") ""))
- #t))))))
+ #t)))
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a running X server.
+ (system "Xvfb :1 +extension GLX &")
+ (setenv "DISPLAY" ":1")
+ ;; Tests write to $HOME.
+ (setenv "HOME" (getcwd))
+ ;; Tests look for $XDG_RUNTIME_DIR.
+ (setenv "XDG_RUNTIME_DIR" (getcwd))
+ ;; For missing '/etc/machine-id'.
+ (setenv "DBUS_FATAL_WARNINGS" "0")
+ #t)))))
(propagated-inputs
- `(("gst-plugins-base" ,gst-plugins-base)))
+ `(("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)))
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("gst-plugins-good" ,gst-plugins-good) ;for tests
+ ("perl" ,perl)
("pkg-config" ,pkg-config)
- ("python" ,python)))
+ ("python" ,python-wrapper)
+ ("xorg-server" ,xorg-server-for-tests)))
(inputs
;; XXX: The following dependencies are missing:
;; vo-amrwbenc, vo-aacenc, bs2b, chromaprint, directfb, daala, libdts,