summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-02 00:25:19 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:23 -0500
commitb59ad1e176bf9cf771e39670873d680da7dda8ff (patch)
treee3e66468fa3d1a7ba7851ea11b14d00b8984aaaf /gnu/packages/gstreamer.scm
parent543367ae89d748499b2b4bf70a6ee0830f727e9a (diff)
downloadguix-patches-b59ad1e176bf9cf771e39670873d680da7dda8ff.tar
guix-patches-b59ad1e176bf9cf771e39670873d680da7dda8ff.tar.gz
gnu: gst-plugins-ugly: Update to 1.19.2.
* gnu/packages/gstreamer.scm (gst-plugins-ugly): Update to 1.19.2. Delete trailing #t. [patches]: Delete field. [meson]: Use meson-0.55. * gnu/packages/patches/gst-plugins-ugly-fix-out-of-bound-reads.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 3b6fe05f78..efa5b2c5c9 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -890,19 +890,19 @@ par compared to the rest.")
(define-public gst-plugins-ugly
(package
(name "gst-plugins-ugly")
- (version "1.18.4")
+ (version "1.19.2")
(source
(origin
(method url-fetch)
(uri
(string-append "https://gstreamer.freedesktop.org/src/"
name "/" name "-" version ".tar.xz"))
- (patches (search-patches "gst-plugins-ugly-fix-out-of-bound-reads.patch"))
(sha256
- (base32 "0g6i4db1883q3j0l2gdv46fcqwiiaw63n6mhvsfcms1i1p7g1391"))))
+ (base32 "1pwz68qg40018ai655fdrjn5clmn0gp2b7dik0jzwx0fzbwzr87j"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ `(#:meson ,meson-0.55
+ #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:phases
(modify-phases %standard-phases
,@%common-gstreamer-phases
@@ -916,8 +916,7 @@ par compared to the rest.")
;; Tests look for $XDG_RUNTIME_DIR.
(setenv "XDG_RUNTIME_DIR" (getcwd))
;; For missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- #t)))))
+ (setenv "DBUS_FATAL_WARNINGS" "0"))))))
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")