summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-02-10 18:43:34 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:14 -0500
commitaf47bb01aea5e3f1d079ad511451d01d1797294d (patch)
tree9649104de8b605957a38ce846384dde45f327fe7 /gnu/packages/gstreamer.scm
parent2a9739b114bae2a55f5cdd44006e1fff8c03443a (diff)
downloadguix-patches-af47bb01aea5e3f1d079ad511451d01d1797294d.tar
guix-patches-af47bb01aea5e3f1d079ad511451d01d1797294d.tar.gz
gnu: gst-plugins-base: Depend on Opus for all systems.
* gnu/packages/gstreamer.scm (gst-plugins-base)[inputs]: Include opus unconditionally.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm6
1 files changed, 1 insertions, 5 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index d6c2fb3f46..46902bb3d2 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -559,11 +559,7 @@ This package provides the core library and elements.")
("libXext" ,libxext)
("libxv" ,libxv)
("alsa-lib" ,alsa-lib)
- ;; XXX Don't build with opus on 32-bit systems:
- ;; <https://bugs.gnu.org/32360>
- ,@(if (target-64bit?)
- `(("opus" ,opus))
- '())))
+ ("opus" ,opus)))
(native-inputs
`(("pkg-config" ,pkg-config)
("glib:bin" ,glib "bin")