summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-01 23:03:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 10:31:23 -0500
commita9e83d7c7e16e2bc3a9e9a9ab9d818b4f5ff10ed (patch)
treed5cc496304075a0d409c3fadcca36f9356df7bc8 /gnu/packages/gstreamer.scm
parent8f22b547ef7bf0a0c3ca5712589c8c02731431ca (diff)
downloadguix-patches-a9e83d7c7e16e2bc3a9e9a9ab9d818b4f5ff10ed.tar
guix-patches-a9e83d7c7e16e2bc3a9e9a9ab9d818b4f5ff10ed.tar.gz
gnu: gst-plugins-good: Update to 1.19.2.
* gnu/packages/gstreamer.scm (gst-plugins-good): Update to 1.19.2. Remove trailing #t. [patches]: Remove. [meson]: Use meson-0.55. * gnu/packages/patches/gst-plugins-good-CVE-2021-3497.patch: Delete file. * gnu/packages/patches/gst-plugins-good-CVE-2021-3498.patch: Likewise. * gnu/packages/patches/gst-plugins-good-fix-test.patch: Likewise. * gnu/local.mk: De-register them.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 9360a06fba..a4c9ed5fb5 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -612,7 +612,7 @@ for the GStreamer multimedia library.")
(define-public gst-plugins-good
(package
(name "gst-plugins-good")
- (version "1.18.4")
+ (version "1.19.2")
(source
(origin
(method url-fetch)
@@ -620,14 +620,12 @@ for the GStreamer multimedia library.")
(string-append
"https://gstreamer.freedesktop.org/src/" name "/"
name "-" version ".tar.xz"))
- (patches (search-patches "gst-plugins-good-fix-test.patch"
- "gst-plugins-good-CVE-2021-3497.patch"
- "gst-plugins-good-CVE-2021-3498.patch"))
(sha256
- (base32 "1c1rpq709cy8maaykyn1n0kckj9c6fl3mhvixkk6xmdwkcx0xrdn"))))
+ (base32 "0bjfipap6wc3w28hgf817hc6jvjbblkjil42a356vg242412xsab"))))
(build-system meson-build-system)
(arguments
- `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ `(#:meson ,meson-0.55
+ #:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
#:phases
(modify-phases %standard-phases
,@%common-gstreamer-phases
@@ -641,8 +639,7 @@ for the GStreamer multimedia library.")
;; Tests look for $XDG_RUNTIME_DIR.
(setenv "XDG_RUNTIME_DIR" (getcwd))
;; For missing '/etc/machine-id'.
- (setenv "DBUS_FATAL_WARNINGS" "0")
- #t)))))
+ (setenv "DBUS_FATAL_WARNINGS" "0"))))))
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")