summaryrefslogtreecommitdiff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-21 22:10:02 +0200
committerMarius Bakke <marius@gnu.org>2020-05-26 22:36:06 +0200
commita64eeaf75585b1871526a226f8cf02064668b74d (patch)
tree3e4a6fdc15aec7924ce2e061cf2821db15a9aa1c /gnu/packages/gstreamer.scm
parent0c8a51c7d28befa49e596421de22c0b4fef100f0 (diff)
downloadguix-patches-a64eeaf75585b1871526a226f8cf02064668b74d.tar
guix-patches-a64eeaf75585b1871526a226f8cf02064668b74d.tar.gz
gnu: gstreamer: Increase test timeouts.
Fixes <https://bugs.gnu.org/36464>. Reported by Steffen Rytter Postas <nc@scalehost.eu>. * gnu/packages/gstreamer.scm (%common-gstreamer-phases): New variable. (gstreamer, gst-plugins-base, gst-plugins-good, gst-plugins-bad, gst-plugins-ugly, gst-editing-services)[arguments]: Use it.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm24
1 files changed, 22 insertions, 2 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 7596796d68..69fb1d8ae4 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -104,6 +104,17 @@ arrays of data.")
;; under the 3-clause BSD license, the rest is under 2-clause BSD license.
(license (list license:bsd-2 license:bsd-3))))
+;; Increase the test timeouts to accommodate slow or busy machines.
+(define %common-gstreamer-phases
+ '((add-after 'unpack 'increase-test-timeout
+ (lambda _
+ (substitute* "tests/check/meson.build"
+ (("'CK_DEFAULT_TIMEOUT', '20'")
+ "'CK_DEFAULT_TIMEOUT', '60'")
+ (("timeout ?: 3 \\* 60")
+ "timeout: 9 * 60"))
+ #t))))
+
(define-public gstreamer
(package
(name "gstreamer")
@@ -122,6 +133,7 @@ arrays of data.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ ,@%common-gstreamer-phases
;; FIXME: Since switching to the meson-build-system, two tests
;; started failing on i686. See
;; <https://gitlab.freedesktop.org/gstreamer/gstreamer/issues/499>.
@@ -220,12 +232,13 @@ This package provides the core library and elements.")
("gobject-introspection" ,gobject-introspection)
("python-wrapper" ,python-wrapper)))
(arguments
- '(#:configure-flags '("-Dgl=disabled"
+ `(#:configure-flags '("-Dgl=disabled"
;; FIXME: Documentation fails to build without
;; enabling GL above, which causes other problems.
"-Ddoc=false")
#:phases
(modify-phases %standard-phases
+ ,@%common-gstreamer-phases
(add-before 'configure 'patch
(lambda _
(substitute* "tests/check/libs/pbutils.c"
@@ -284,6 +297,7 @@ for the GStreamer multimedia library.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ ,@%common-gstreamer-phases
,@(if (string-prefix? "arm" (or (%current-target-system)
(%current-system)))
;; FIXME: These tests started failing on armhf after switching to Meson.
@@ -332,6 +346,7 @@ developers consider to have good quality code and correct functionality.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ ,@%common-gstreamer-phases
,@(if (string-prefix? "arm" (or (%current-target-system)
(%current-system)))
;; Disable test that fails on ARMv7.
@@ -421,6 +436,9 @@ par compared to the rest.")
(base32
"1jpvc32x6q01zjkfgh6gmq6aaikiyfwwnhj7bmvn52syhrdl202m"))))
(build-system meson-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ ,@%common-gstreamer-phases)))
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
("liba52" ,liba52)
@@ -492,7 +510,9 @@ compression formats through the use of the libav library.")
(build-system meson-build-system)
(arguments
;; FIXME: 16/22 failing tests.
- `(#:tests? #f))
+ `(#:tests? #f
+ #:phases (modify-phases %standard-phases
+ ,@%common-gstreamer-phases)))
(inputs
`(("gst-plugins-base" ,gst-plugins-base)
("libxml2" ,libxml2)))